POJ--3984--迷宫问题

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11806 Accepted: 7072

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
思路:广搜,但是需要用栈来记录路径,具体的就看代码吧。不是很难,应该能看懂。
ac代码:
#include<stdio.h>
#include<stack>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
int map[5][5],vis[110][110],cx[4]={0,0,1,-1},cy[4]={1,-1,0,0};
struct node{//prex和prey用来记录路径 
	int x,y,prex,prey,step;
	friend bool operator < (node a,node b){
		return a.step>b.step;
	}
}now,next,path[5][5];
struct pre{ //专门用来记录路径,因为路径是从终点回到起点的,所以放到栈里比较合适。 
	int x,y;
};
int jud(int x,int y){//判断这一步是否合法。 
	if(x<0||x>4||y<0||y>4)
		return 0;
	if(vis[x][y]==1||map[x][y])
		return 0;
return 1;
}
void print(int sx,int sy){
	stack<pre>p;
	pre temp={sx,sy};
	node rec;//记录路径用。 
	p.push(temp);
	while(1){
		rec=path[temp.x][temp.y];
		temp.x=rec.prex;
		temp.y=rec.prey;
		p.push(temp);
		if(temp.x==0&&temp.y==0)
			break; 
	}
	while(!p.empty()){
		temp=p.top();
		p.pop();
		printf("(%d, %d)\n",temp.x,temp.y);
	}
}
void bfs(){
	priority_queue<node>q;
	now.x=now.y=now.step=0;
	q.push(now);
	memset(vis,0,sizeof(vis));
	vis[0][0]=1;
	while(!q.empty()){
		now=q.top();
		q.pop();
		if(now.x==4&&now.y==4){
			path[now.x][now.y]=now; 
			print(4,4);
			return ;
		}
		for(int i=0;i<4;i++){
			next.x=now.x+cx[i];
			next.y=now.y+cy[i];
			next.step=now.step+1;
			if(jud(next.x,next.y)){
				vis[next.x][next.y]=1;
				next.prey=now.y;
				next.prex=now.x;
				next.step=now.step+1;
				path[next.x][next.y]=next;
				if(next.x==4&&next.y==4){
					print(4,4);
					return ;
				}
				q.push(next);
			}
		}
	} 
}
int main(){
	for(int i=0;i<5;i++)
		for(int j=0;j<5;j++)
			scanf("%d",&map[i][j]);
	bfs();
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值