POJ 3253

Fence Repair

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 47551 Accepted: 15581

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needsN (1 ≤ N ≤ 20,000) planks of wood, each having some integer lengthLi (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into theN planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of theN-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create theN planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
题意:输入n个数代表要修的n个栅栏的长度,现在给你一个最够长的木板,你要用这个木板锯成n个这样的木条,(给定的木板长为这n个木板长度之和,最划算),现在规定每锯一块长为多少的木块就花费多少,(比如你要把长为x的木块锯成x1和x2,那么花费x,即被分割的木块多长就花费多少),问你最少花费多少可以得到这n块木块。
思路:这一题如果对哈夫曼算法熟悉的话,这一题分割的过程就是哈夫曼算法的逆过程,那么用哈夫曼算法,就可以解决这个问题(虽然不是模拟分割过程,但是所得的结果是相同的)我们采用逆向思维,将分割转化为拼接!!首先,含有n个木块得木块堆中找到最小的两个木块,让其拼接得到一块较大的木块,(这里拼接两块所需花费为这两个木块得长度和),将这块拼接好得木块加入到这些木块,从大到小排好序,然后取最小的两个木块,拼接。。。。重复上述步骤,直到所有的木块都拼接成一块为止。(你现在可以把你的这个拼接过程倒着走一遍,你会发现,倒着走时将拼接改为分割就是本题的过程模拟)。
以下给出两种解法:(其实本质都一样,建议用优先队列,这样不容易出错)
#include <iostream>
#include <stdio.h>
#include <queue>
#include <map>

using namespace std;

priority_queue<int, vector<int>, greater<int> > pr;

int main()
{
    long long n, sum = 0;
    cin >> n;
    long long length, min1, min2;
    while(n--)
    {
        scanf("%lld", &length);
        pr.push(length);

    }
    while(pr.size() > 1)
    {
        min1 = pr.top();
        pr.pop();
        min2 = pr.top();
        pr.pop();
        sum += min1 + min2;
        pr.push(min1 + min2);
    }
    cout << sum << endl;
    return 0;
}
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <math.h>

using namespace std;

int main()
{
    long long n, length[20005];
    long long sum = 0;
    cin >> n;
    for(int i = 0; i < n; i++)
    {
        scanf("%lld", &length[i]);
    }
    while(n > 1)
    {
        int min1 = 0, min2 = 1;
        if(length[min1] > length[min2])
        {
            long long t = length[min1];
            length[min1] = length[min2];
            length[min2] = t;
        }
        for(int i = 2; i < n; i++)
        {
            if(length[i] < length[min1])
            {
                min2 = min1;    //切记这两行不能就交换顺序
                min1 = i;
            }
            else if(length[i] < length[min2])
            {
                min2 = i;
            }
        }
        long long t = length[min1] + length[min2];
        sum += t;
        length[min1] = t;
        length[min2] = length[n - 1];  //如何去掉这个length[min2]的值,首先将最后一个元素的值赋给它,再n--;
        n--;//这样既可以使第二小的数删掉,右不会使最后一个元素重复;
    }
    cout << sum << endl;
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值