HDU 1155

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1155

Bungee Jumping

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1363    Accepted Submission(s): 599


Problem Description
Once again, James Bond is fleeing from some evil people who want to see him dead. Fortunately, he has left a bungee rope on a nearby highway bridge which he can use to escape from his enemies. His plan is to attach one end of the rope to the bridge, the other end of the rope to his body and jump off the bridge. At the moment he reaches the ground, he will cut the rope, jump into his car and be gone.

Unfortunately, he had not had enough time to calculate whether the bungee rope has the right length, so it is not clear at all what is going to happen when he jumps off the bridge. There are three possible scenarios:
The rope is too short (or too strong), and James Bond will never reach the ground.
The rope is too long (or too weak), and James Bond will be going too fast when he touches the ground. Even for a special agent, this can be very dangerous. You may assume that if he collides at a speed of more than 10 m/s, he will not survive the impact.
The rope's length and strength are good. James Bond touches the ground at a comfortable speed and can escape.
As his employer, you would like to know whether James Bond survives or whether you should place a job ad for the soon-to-be vacant position in the local newspaper. Your physicists claim that:
The force with which James is pulled towards the earth is
9.81 * w,
where w is his weight in kilograms and 9.81 is the Earth acceleration in meters over squared seconds.
Mr. Bond falls freely until the rope tautens. Then the force with which the bungee rope pulls him back into the sky depends on the current length of the rope and is
k * Δl,
where Δl is the difference between the rope's current length and its nominal, unexpanded length, and k is a rope-specific constant.
Given the rope's strength k, the nominal length of the rope l in meters, the height of the bridge s in meters, and James Bond's body weight w, you have to determine what is going to happen to our hero. For all your calculations, you may assume that James Bond is a point at the end of the rope and the rope has no mass. You may further assume that k, l, s, and w are non-negative and that s < 200.

The input contains several test cases, one test case per line. Each test case consists of four floating-point numbers (k, l, s, and w) that describe the situation. Depending on what is going to happen, your program must print "Stuck in the air.", "Killed by the impact.", or "James Bond survives.". Input is terminated by a line containing four 0s, this line should not be processed.
 

Sample Input
  
  
350 20 30 75 375 20 30 75 400 20 30 75 425 20 30 75 450 20 30 75 400 20 30 50 400 20 30 80 400 20 30 85 0 0 0 0
 

Sample Output
  
  
Killed by the impact. James Bond survives. James Bond survives. James Bond survives. Stuck in the air. Stuck in the air. James Bond survives. Killed by the impact.
 
题意:
给你四个量k、l、s、w,其中k表示弹性绳的劲度系数,l 表示绳子自然状态的长度,s表示桥的高度,w表示James的体重;问题的背景是James要跳桥逃生,他用绳子一头系在桥上,绳子的另一头系在自己身上,他现在要跳下去(联想蹦极这一极限项目)。这样跳下去就会出现三种情况,第一种:绳子短于桥高与和劲度系数过大这两个因素的影响下使得人没办法接触地面,那么输出“被困在空中”;第二种:在各种因素的影响下,人到达地面的速度大于10米每秒,则输出“被撞击而死”,(这里不一定要求绳子很短,只要到达地面的速度达到要求,那他就。。。);第三种:到达地面的速度小于10米每秒,他就会割断绳子逃生,输出“这人幸存”。
理解:
这就是一题纯物理题,首先我们分析他从桥上直接跳下,则到达地面时的动能由动能定理得:e = w * g * s (以地面为参考系,重力势能转化为动能);
若这个绳子短于桥的高,那么在下落过程中,当下降高度小于绳子长时自由落体,当下降高度大于绳子长且小于桥高时变减速运动,现在我们把这个减速过程,弹性势能的增加量求出来,为:0.5 * (s-l)^2 * k;那么直接跳下的动能减去弹性势能的增加就是人到达地面的真实动能;若这个动能值为负则说明人没法到达地面,若这个值为正但通过这个值求出来的速度大于10,则很不幸;不大于10,很幸运!
#include<iostream>
#include<math.h>
#include <stdio.h>
#define g 9.81

using namespace std;

int main()
{
    double k,l,s,w;
    while(~scanf("%lf%lf%lf%lf", &k, &l, &s, &w))
    {
        if(k==0 && l==0 && s==0 && w==0)
            break;
        double e = w*g*s;
        if(s>l)
            e -= k*(s-l)*(s-l)/2;
        if(e<0)
        {
            cout<<"Stuck in the air."<<endl;
            continue;
        }
        double v = sqrt(e*2/w);  //e = 0.5 * w * v^2推导得;
        if(v>10)
            cout<<"Killed by the impact."<<endl;
        else
        cout<<"James Bond survives."<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值