hdu 2095 find your present (2)

find your present (2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 27135    Accepted Submission(s): 10635


Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 

Input
The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

Output
For each case, output an integer in a line, which is the card number of your present.
 

Sample Input
 
 
5 1 1 3 2 2 3 1 2 1 0
 

Sample Output
 
 
3 2
Hint
Hint
use scanf to avoid Time Limit Exceeded
 

Author
8600


方法一:利用STL中的set很容易想到方法:如果是当前存入的数在集合中已存在,则把集合中的这个数给删了,这样偶数个的总会被删完,只留一下一个奇数的就是需要的结果。

//hdu 2095  find your present (2)
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <map>
#include <set>
#include <algorithm>

using namespace std;
set<int> it;

int main(){
	int n;
	int a;
	while(scanf("%d", &n) != EOF && n){
		for(int i = 0; i < n; i++){
			scanf("%d", &a);
			if(it.find(a) == it.end()){
				it.insert(a);
			}
			else
				it.erase(a);
		}
		printf("%d\n", *it.begin());
		it.clear();
	}
	return 0;
}

方法二:利用离散异或的知识知道,

《1》偶数个相同的数异或结果是0;

《2》奇数个相同的数异或结果是这个数本身;

《3》0与任何数异或的这个数;

这样我们就有方法了,对于输入的n个数全部进行异或,这样留下的就是那个出现奇数次的那个数了,就是我们要的结果。

//hdu 2095  find your present (2)
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <map>
#include <set>
#include <algorithm>

using namespace std;

int main()  
{  
    int n,x,ans;  
    while(scanf("%d",&n),n)  
    {  
        ans = 0;  
        while(n--)  
        {  
            scanf("%d",&x);  
            ans ^= x;  
        }  
        printf("%d\n",ans);  
    }  
    return 0;  
}  


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值