二分法解方程

单调函数零点可用二分法求

 基本模板

   double f(double a){}    //单调函数
  ....
  while(right-left>1e-10){
         mid=(right+left)/2;
         if(f(mid)>0)   left=mid;   //根据是递增还是递减判断
         else right=mid;  
  }

对于凹函数或凸函数的极值可用三分法求,当然也可先求导,再二分求极值点

基本模板

  double f(double a){}    //函数
  ....
  while(right-left>1e-10){
         mid=(right+left)/2;
         mmid=(mid+right)/2;
         if(f(mid)>f(mmid))   right=mid;   //根据是凹还是凸判断
         else left=mid;  
  }



题目1:hdoj2199

  

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);Output For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.Sample Input
2
100
-4
Sample Output
1.6152
No solution!


思路分析:当函数在区间与X轴没交点时,无解


#include<iostream>
#include<cmath>
#include<stdio.h>
using namespace std;
double c;
double f(double x){
         double y;
         y=8*pow(x,4)+7*pow(x,3)+2*x*x+3*x+c;
         return y;
}
int main(){
     double y,a,b,mid;
     int t;
     cin>>t;
     while(t--){
        cin>>y;
        c=6-y;
        if(f(100)<=0||f(0)>=0) cout<<"No solution!"<<endl;
        else{
            a=0;
            b=100;
            mid=(a+b)/2;
            while(abs(b-a)>0.0000001){
                if(f(mid)>0) b=mid;
                else a=mid;
                mid=(a+b)/2;

            }
            printf("%.4f\n",mid);
        }
     }
     return 0;
}

题目2:hdoj2899

Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)Output Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.Sample Input
2
100
200
Sample Output
-74.4291
-178.8534

#include<iostream>
#include<cmath>
#include<stdio.h>
using namespace std;
double y;
double f1(double x){   //导函数
    double ans;
    ans=42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x-y;
    return ans;
}
double f2(double x){  //原函数
    double ans;
    ans=6*pow(x,7)+8*pow(x,6)+7*x*x*x+5*x*x-y*x;
    return ans;
}
int main(){
    double a,b,mid;
    int t;
    cin>>t;
    while(t--){
        cin>>y;
        if(f1(0)>=0) printf("%.4f\n",f2(0));
        if(f1(100)<=0) printf("%.4f\n",f2(100));
        else{
            a=0;
            b=100;
            mid=(a+b)/2;
            while(abs(b-a)>0.00000001){
                if(f1(mid)>0) b=mid;
                else a=mid;
                mid=(a+b)/2;
            }
            printf("%.4f\n",f2(a));

        }
    }
    return 0;
}






  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值