Fibonacci Again

Fibonacci Again

Time Limit: 1000ms   Memory limit: 32768K  有疑问?点这里^_^

题目描述

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

输入

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

输出

Print the word "yes" if 3 divide evenly into F(n). Print the word "no" if not.

示例输入

0
1
2
3
4
5

示例输出

no
no
yes
no
no
no

提示

hdoj1021  有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。

来源

Leojay

#include<stdio.h>
int set(int n)
{
	int p;
	if(n==0)
		p=7;
	if(n==1)
		p=11;
	if(n>=2)
		p=set(n-1)+set(n-2);
return p;
}
int main()
{
	int n,m,a,b;
	while(scanf("%d",&n)!=EOF)
	{
		m=set(n);
		if(m%3==0)
			printf("yes\n");
		else
			printf("no\n");
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值