Cow Multiplication

Cow Multiplication

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, A*B is equal to the sum of all possible pairwise products between the digits of A and B. For example, the product 123*45 is equal to 1*4 + 1*5 + 2*4 + 2*5 + 3*4 + 3*5 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie\'s style of multiplication.

 

输入

  * Line 1: Two space-separated integers:   A   and   B .

输出

  * Line 1: A single line that is the A*B in Bessie\'s style of multiplication.

示例输入

123 45

示例输出

54

提示

 

来源

 

示例程序

 
#include<stdio.h>    
#include<string.h>    
int main()    
{    
    int i,j,n,m,k=0,t;    
    char a[100],b[100];    
    scanf("%s %s",a,b);    
    n=strlen(a);    
    m=strlen(b);    
    for(i=0;i<n;i++)    
        for(j=0;j<m;j++)    
            k+=(a[i]-'0')*(b[j]-'0');    
        printf("%d\n",k);    
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值