Cow Multiplication
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, A*B is equal to the sum of all possible pairwise products between the digits of A and B. For example, the product 123*45 is equal to 1*4 + 1*5 + 2*4 + 2*5 + 3*4 + 3*5 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie\'s style of multiplication.
输入
* Line 1: Two space-separated integers:
A
and
B
.
输出
* Line 1: A single line that is the A*B in Bessie\'s style of multiplication.
示例输入
123 45
示例输出
54
提示
来源
示例程序
#include<stdio.h>
#include<string.h>
int main()
{
int i,j,n,m,k=0,t;
char a[100],b[100];
scanf("%s %s",a,b);
n=strlen(a);
m=strlen(b);
for(i=0;i<n;i++)
for(j=0;j<m;j++)
k+=(a[i]-'0')*(b[j]-'0');
printf("%d\n",k);
}