This is an A+B Problem

This is an A+B Problem

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

As usual, there will be an A+B problem in warming up, this problem is:
Given two integers A and B, your job is to calculate the sum of A + B.

输入

  Th ere are several test cases, For each test case:
There are two integers A, B for each case (0  A , B < 101000).

输出

  For each test case, output one line containing the result of A+B. 

示例输入

1 2
11111111111 11111111111

示例输出

3
22222222222

提示

 

来源

 

示例程序

 
#include<stdio.h>    
#include<string.h>    
char a[2000],b[2000],c[2000];    
int main()    
{    
int i,j,n,m,k,t,l;    
memset(a,0,sizeof(a));    
memset(b,0,sizeof(b));    
while(scanf("%s %s",a,b)!=EOF)    
{    
memset(c,0,sizeof(c));    
n=strlen(a);    
m=strlen(b);    
l=0;    
//printf("%s %s\n",a,b);    
for(i=n-1,j=m-1;j>=0&&i>=0;i--,j--)    
c[l++]=a[i]+b[j]-48;    
if(i!=-1)    
for(;i>=0;)    
c[l++]=a[i--];    
if(j!=-1)    
for(;j>=0;)    
c[l++]=b[j--];    
    
//if(c[l-1]>=58)    
//l++;    
for(k=0;k<l;k++)    
if(c[k]>=58)    
{    
c[k]=c[k]-10;    
c[k+1]+=1;    
}    
if(c[k]!=0)    
{    
printf("%c",c[k]+48);    
}    
for(t=l-1;t>=0;t--)    
printf("%c",c[t]);    
printf("\n");    
}    
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值