1006. Sign In and Sign Out (25)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

题目大意:

在每天的开始,第一个在机房签到的人会打开门,最后一个签退的人会锁上门。你的任务是根据给定的签到和签退的记录找到在那天开门和锁门的人。
输入规格:
每个输入文件包含一个测试用例。每个案例包含一天的记录。这个例子的开头是一个正整数M,它是记录的总数,接下来是M行,每行的格式如下:
ID_number Sign_in_time Sign_out_time
时间的格式是:HH:MM:SS,ID号是一个不超过15个字符的字符串。
输出规范:
对于每个测试用例,在一行中输出那天开门和锁门的人的ID号。两个ID号中间用空格隔开。
注:保证记录是合理的,也就是说开门的人要比关门的人来的时间早,而且在同一时刻不能有两人同时签到。

代码:

#include<bits/stdc++.h>
int main()
{
    int m;
    char id[20],in[20],out[20],early_id[20],early_in[20],last_id[20],last_out[20];
    scanf("%d",&m);
    scanf("%s %s %s",id,in,out);
    strcpy(early_id,id);
    strcpy(early_in,in);
    strcpy(last_id,id);
    strcpy(last_out,out);
    m--;
    while(m--)
    {
        scanf("%s %s %s",id,in,out);
        if(strcmp(in,early_in)<0)
        {
           strcpy(early_in,in);
           strcpy(early_id,id);
        }
        if(strcmp(out,last_out)>0)
        {
           strcpy(last_id,id);
           strcpy(last_out,out);
        }
    }
    printf("%s %s",early_id,last_id);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值