1009. Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

题目大意:

这次,你应该找到A*B,其中A和B是两个多项式。
输入规格:
每一个输入文件包含一个测试用例。每个案占2行,每一行包含一个多项式的信息:K N1 aN1 N2 aN2 ... NK aNK, K是多项式中非零项的个数,Ni和aNi (i= 1,2,…K)分别是指数和系数。给定1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.
输出规范:
对于每个测试用例你应该在一行中输出A和B的乘积,与输入格式相同。注意,在每一行的末尾没有多余的空格。请精确到小数点后一位。

代码:

#include<stdio.h>
double a[1001],b[1001],c[2001];
int main()
{
    int i,j,n,m,k,t,count=0;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d",&k);
        scanf("%lf",&a[k]);
    }
    scanf("%d",&m);
    for(i=0;i<m;i++)
    {
        scanf("%d",&t);
        scanf("%lf",&b[t]);
    }
    for(i=0;i<1001;i++)
    {
        if(a[i]!=0)
        {
            for(j=0;j<1001;j++)
            {
                if(b[j]!=0)
                {
                    c[i+j]+=a[i]*b[j];
                }
            }
        }
    }
    for(i=2000;i>=0;i--)
    {
        if(c[i]!=0)
        {
            count++;
        }
    }
    printf("%d",count);
    for(i=2000;i>=0;i--)
    {
        if(c[i]!=0)
        {
            printf(" %d %.1lf",i,c[i]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值