1031. Hello World for U (20)

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1 characters, then left to right along the bottom line with n 2 characters, and finally bottom-up along the vertical line with n 3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n 1 = n 3 = max { k| k <= n 2 for all 3 <= n 2 <= N } with n 1 + n 2 + n 3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor

题目大意:

给定任意N个字符的字符串,要求你将字符组成u的形状,例如,“helloworld!”可以打印为:
h  d
e  l
l  r
lowo
也就是说,字符必须以原始顺序打印出来,从左侧的垂直行开始打印n1个字符,然后沿着底部打印一行n2个字符,最后沿着底部垂直向上打印n3个字符。而且,我们希望U尽可能的成方形,也就是说,他必须满足n1=n3=max{k|k<=n2,所有的3<=n2<=N},n1+n2+n3-2=N.
输入规格:
每一个输入文件包含一个测试用例。每个测试用例包含一个不小于5也不大于80个字符的字符串。该字符串中不包含空格。
输出规格:
对于每个测试用例,按照描述中指定的U的形状打印输入字符串。

代码:

#include<stdio.h>
#include<string.h>
int main()
{
    int i,j,n,m,k,t,n1,n2;
    char str[100];
    scanf("%s",str);
    n=strlen(str);
    m=(n+2)/3;
    k=n-2*(m-1)-2;
    for(i=0;i<m-1;i++)
        {
            printf("%c",str[i]);
            for(j=0;j<k;j++)
                printf(" ");
            printf("%c\n",str[n-i-1]);

        }
        for(i=m-1;i<n-m+1;i++)
            printf("%c",str[i]);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值