[C/C++] 1031 Hello World for U (20 分)

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1 characters, then left to right along the bottom line with n2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1=n3=max { k | k≤n2​​ for all 3≤n2​​ ≤N } with n1+n2+n3−2=N.

Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:
For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

要求:n1=n3<=n2而且n1尽可能大
思路:
n1+n2+n3-2=len -> n2=len+2-2n1
n2>=n1 -> n1<=(len+2)/3
在这里插入图片描述
对于非最后一行(n1-1行):p指向首,q指向尾,先输出a[p],再输出n2-2个空格,再输出a[q]
对于最后一行:从p遍历到q,依次输出
1.

#include<stdio.h>
#include<string.h>

int main()
{
	char a[85];
	scanf("%s",a);
	int len = strlen(a); 
	int n1, n2;
	n1 = (len+2)/3;//向下取整 
	n2 = len-2*n1+2;

	int p=0, q=len-1;
	for( int i=0; i<n1-1; i++){
		printf("%c",a[p]);
		for(int j=0; j<n2-2; j++){
			printf(" ");
		}	
		printf("%c\n",a[q]);
		p++;
		q--;
	}
	
	for( int i=p; i<=q; i++){
		printf("%c",a[i]);
	}
	
	return 0;
}

计算n2还有一种办法,枚举

for( n2=0; n2<=len; n2++ ){
	if( (len-n2)%2==0 ){//n1和n3可以平均分 
		n1 = (len-n2+2)/2;
		if( n2>=n1 ) break; 
	}
}

柳婼小姐姐的方法
在这里插入图片描述
2.二维数组

#include<stdio.h>
#include<string.h>

int main()
{
	char a[85],ans[40][40];
	scanf("%s",a);
	int len = strlen(a); 
	int n1, n2;
	n1 = (len+2)/3;//向下取整 
	n2 = len-2*n1+2;
	
	for( int i=0; i<n1; i++){//初始化ans数组为空格 
		for( int j=0; j<n2; j++){
			ans[i][j] = ' ';
		}
	}
	
	int pos = 0;//用来遍历a
	for( int i =0; i<n1; i++){//n1
		ans[i][0] = a[pos++];
	} 
	for( int i =1; i<n2; i++){//n2
		ans[n1-1][i] = a[pos++];
	}
	for(int i=n1-2; i>=0; i--){//n3
		ans[i][n2-1] = a[pos++];
	}
	
	for( int i=0; i<n1; i++){//输出 
		for( int j=0; j<n2; j++){
			printf("%c",ans[i][j]);
		}
	 	if(i<n1-1) printf("\n");
	}
	
	return 0;
}
  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值