1031 Hello World for U (20)(20 分)

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n~1~ characters, then left to right along the bottom line with n~2~ characters, and finally bottom-up along the vertical line with n~3~ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n~1~ = n~3~ = max { k| k <= n~2~ for all 3 <= n~2~ <= N } with n~1~

  • n~2~ + n~3~ - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题解:就是左边为n1右边为n3 下面为n2

要求 n1=n3  && n1<=n2 emm 题目我有点看不太懂

然后需要注意的一点就是 左边假设一列为k 右边也为k 那么底部剩下的是len-2*k但是吧其实是len+2-k*2 

因为要尽可能的围城正方形 所以这边需要稍微注意下 我觉得题还不错

代码:

#include<bits/stdc++.h>
using namespace std;
char maze[100][100];
int main ()
{
	char str[100];
	scanf("%s",str+1);
	int len=strlen(str+1);
	int k=(len+2)/3;
	int bott=len-2*k,i;
	for(int i=1;i<=k;i++)
	{
		int j; 
		for(j=1;j<=bott+2;j++)//其实应该包括第一列和最后一列的 
			maze[i][j]=' '; 
		maze[i][j]='\0';
	}	

	for(i=1;i<=k;i++) 
		maze[i][1]=str[i];//第一列 
	int now=1;
	int y=i-1;
	for(;i<=y+bott;i++)
		maze[k][++now]=str[i];
	++now;
	int tt=k;
	for(;i<=len;i++)
		maze[tt--][now]=str[i];
	for(int i=1;i<=k;i++)
			printf("%s\n",maze[i]+1); 
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值