1050. String Subtraction (20)

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.

题目大意:

给定两个字符串S1和S2,S=s1-S2被定义为从S1中提取S2中的所有字符后得到剩余的字符串S。你的任务是简单计算任意给定的字符串S1-S2,然而,做起来不可能那么简单。
输入规格:
每个输入文件包含一个测试用例。每个测试用例分别由给定的字符串S1和S2组成。两个字符串的长度都不超过10的4次方。保证所有字符都是可见的ASCII码和空格,一个新的行字符表示字符串的结束。
输出规范:
对于每个测试用例,在一行中打印S1-S2。

代码:

#include<stdio.h>
char str[10001];
char str1[100001];
int arr[1000];
int main()
{
    int i,j,n,m,k,t;
    gets(str);
    gets(str1);
    for(i=0;str1[i]!='\0';i++)
    {
        arr[str1[i]]=1;
    }
    for(i=0;str[i]!='\0';i++)
    {
        if(arr[str[i]]==0)
        printf("%c",str[i]);
    }
    printf("\n");
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值