#1050. String Subtraction【哈希】

原题链接

Problem Description:

Given two strings S 1 S_1 S1 and S 2 S_2 S2 S = S 1 − S 2 S = S_1 - S_2 S=S1S2 is defined to be the remaining string after taking all the characters in S 2 S_2 S2 from S 1 S_1 S1. Your task is simply to calculate S 1 − S 2 S_1 - S_2 S1S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S 1 S_1 S1 and S 2 S_2 S2, respectively. The string lengths of both strings are no more than 1 0 4 10^4 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S 1 − S 2 S_1 −S_2 S1S2 in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

Problem Analysis:

遍历一遍字符串 b,将出现过的字符用哈希做标记,在遍历一遍字符串 a,将没有被标记过的字符输出即可。另外由于这里的字符串可能有空格,需要用 getline 进行读入。

Code

#include <cstdio>
#include <cstring>
#include <iostream>
#include <unordered_map>

using namespace std;

const int N = 1e4 + 10;

unordered_map<char, int> map;

int main()
{
    string a, b;
    getline(cin, a);
    getline(cin, b);

    for (int i = 0; i < b.size(); i ++ )
    {
        map[b[i]] ++ ;
    }

    for (int i = 0; i < a.size(); i ++ )
    {
        if (map[a[i]] == 0) printf("%c", a[i]);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值