If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.
Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.
Output Specification:
For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d1...dN*10^k" (d1>0 unless the number is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.
Note: Simple chopping is assumed without rounding.
Sample Input 1:3 12300 12358.9Sample Output 1:
YES 0.123*10^5Sample Input 2:
3 120 128Sample Output 2:
NO 0.120*10^3 0.128*10^3
题目大意:
代码:
#include<stdio.h>
#include<string.h>
char A[1000],B[1000],a[1000],b[1000];
int main()
{
int i,j,n,cnta,cntb,pa,pb,indexa,indexb;
scanf("%d %s %s",&n,a,b);
cnta=strlen(a);
cntb=strlen(b);
for(i=0;i<strlen(a);i++)
{
if(a[i]=='.')
{
cnta=i;
break;
}
}
for(i=0;i<strlen(b);i++)
{
if(b[i]=='.')
{
cntb=i;
break;
}
}
pa=0;
while(a[pa]=='0'||a[pa]=='.')
pa++;
pb=0;
while(b[pb]=='0'||b[pb]=='.')
pb++;
if(cnta>=pa)
{
cnta=cnta-pa;
}
else
{
cnta=cnta-pa+1;
}
if(cntb>=pb)
{
cntb=cntb-pb;
}
else
{
cntb=cntb-pb+1;
}
if(pa==strlen(a))
cnta=0;
if(pb==strlen(b))
cntb=0;
indexa=0;
while(indexa<n)
{
if(a[pa]!='.'&&pa<strlen(a))
{
A[indexa++]=a[pa];
}
else if(pa>=strlen(a))
{
A[indexa++]='0';
}
pa++;
}
A[indexa]='\0';
indexb=0;
while(indexb<n)
{
if(b[pb]!='.'&&pb<strlen(b))
{
B[indexb++]=b[pb];
}
else if(pb>=strlen(b))
{
B[indexb++]='0';
}
pb++;
}
B[indexb]='\0';
if(strcmp(A,B)==0&&cnta==cntb)
{
printf("YES 0.%s*10^%d\n",A,cnta);
}
else
{
printf("NO 0.%s*10^%d 0.%s*10^%d\n",A,cnta,B,cntb);
}
return 0;
}
参考:
柳婼