Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.
Sample Input:7 1 2 3 4 5 6 7 2 3 1 5 4 7 6Sample Output:
3
题目大意:
代码:
#include<stdio.h>
#include<algorithm>
#include<stdlib.h>
using namespace std;
int a[50010];
int b[50010];
struct node
{
int data;
struct node *lchild,*rchild;
};
struct node * create(int n,int *a,int *b)
{
if(n<=0)
{
return NULL;
}
struct node *root=(struct node *)malloc(sizeof(struct node));
root->data=b[0];
int *p;
for(p=a;p-a<n;p++)
{
if(*p==b[0])
break;
}
int t=p-a;
root->lchild=create(t,a,b+1);
root->rchild=create(n-t-1,p+1,b+t+1);
return root;
}
void postorder(struct node *root)
{
if(root!=NULL)
{
postorder(root->lchild);
postorder(root->rchild);
printf("%d",root->data);
exit(0);
}
}
int main()
{
int i,j,n;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&b[i]);
}
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
struct node *root=create(n,a,b);
postorder(root);
return 0;
}