Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.
Sample Input:7 1 2 3 4 5 6 7 2 3 1 5 4 7 6Sample Output:
3题目解析:
给出前序和中序,找出后序排列的第一个点。常规题了。
#include <cstdio>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <map>
#include <set>
#include <queue>
#include <vector>
#include <stack>
#include <algorithm>
#include <iostream>
using namespace std;
#define long long ll
const int MAXN = 5e4 + 10;
const int INF = 0x7fffffff;
const int dx[]={0, 1, 0, -1};
const int dy[]={1, 0, -1, 0};
int In_order[MAXN], Pre_order[MAXN];
int Dfs(int Pre_x, int Pre_y, int In_x, int In_y){
int In_root;
for(int i=In_x; i<=In_y; i++){
if(Pre_order[Pre_x]==In_order[i]){
In_root=i;break;
}
}///printf("%d %d %d %d\n", In_root, Pre_order[Pre_x], In_x, In_y);
int left_remain=In_root -In_x;
int right_remain=In_y-In_root;
int ans=In_order[In_root];
if(left_remain){///有左子树
Dfs(Pre_x+1, Pre_x+left_remain, In_x, In_root-1);
}else if(right_remain){///无左子树,有右子树
Dfs(Pre_x+1, Pre_x+right_remain, In_root+1, In_y);
}else printf("%d\n", In_order[In_root]);
///
}
int main(){
int n;
while(~scanf("%d", &n)){
for(int i=1; i<=n; i++) scanf("%d", &Pre_order[i]);
for(int i=1; i<=n; i++) scanf("%d", &In_order[i]);
Dfs(1, n, 1, n);
///printf("%d\n", Dfs(1, n, 1, n));
}
return 0;
}