1130. Infix Expression(25)

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( <= 20 ) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by -1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

Figure 1

Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

题目大意:

给定中缀表达式二叉树,输出中缀表达式。需要注意的是括号(parentheses)的输出,二叉树的根节点和叶子结点不需要输出括号。在程序中加以限制即可。

代码:

#include<stdio.h>
struct node
{
    char data[50];
    int lchild;
    int rchild;
}tree[50];
int a[50],Root;
void inorder(int root)
{
   if(root==-1)
        return ;
   if(root!=Root&&(tree[root].lchild!=-1||tree[root].rchild!=-1))
    printf("(");
   inorder(tree[root].lchild);
   printf("%s",tree [root].data);
   inorder(tree[root].rchild);
   if(root!=Root&&(tree[root].lchild!=-1||tree[root].rchild!=-1))
    printf(")");
}
int main()
{
    int i,j,n,m,k,t;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
        scanf("%s %d %d",&tree[i].data,&tree[i].lchild,&tree[i].rchild);
        if(tree[i].lchild!=-1)
        a[tree[i].lchild]=1;
        if(tree[i].rchild!=-1)
        a[tree[i].rchild]=1;
    }
    for(i=1;i<=n;i++)
    {
        if(a[i]==0)
        {
            Root=i;
            break;
        }
    }
    inorder(Root);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值