给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:7 2 3 1 5 7 6 4 1 2 3 4 5 6 7输出样例:
4 1 6 3 5 7 2
代码:
#include<stdio.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<vector>
using namespace std;
vector<int> v;
int l=0;
struct node
{
int data;
struct node *lchild,*rchild;
};
struct node *create(int n,int a[],int b[])
{
if(n<=0)
{
return NULL;
}
struct node *root=(struct node *)malloc(sizeof(struct node));
root->data=b[n-1];
int *p;
for(p=a;*p!=b[n-1];p++);
int t=p-a;
root->lchild=create(t,a,b);
root->rchild=create(n-t-1,p+1,b+t);
return root;
}
void level(struct node *root)
{
queue<struct node *> q;
q.push(root);
while(!q.empty())
{
struct node *tmp=q.front();
q.pop();
if(tmp!=NULL)
{
v.push_back(tmp->data);
q.push(tmp->lchild);
q.push(tmp->rchild);
}
}
}
void preorder(struct node *root)
{
if(root!=NULL)
{
printf("%d ",root->data);
preorder(root->lchild);
preorder(root->rchild);
}
}
int main()
{
int i,j,n,m,k,t;
int a[50],b[50];
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&b[i]);
}
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
struct node *root=create(n,a,b);
level(root);
for(i=0;i<v.size();i++)
{
if(i==0)
{
printf("%d",v[i]);
}
else
{
printf(" %d",v[i]);
}
}
return 0;
}