HDU 1829 A Bug's Life (并查集)

15 篇文章 0 订阅

  1. 题意:题意:有n个人,给你m对关系,问有没有同性恋的。 

Problem Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
#include <algorithm>
#include <iomanip>
#include <set>

using namespace std;
const int inf = 10000000;
const int maxn = 1000000;

int f[maxn];  //f[x]=y 表示x是y的同性 
int h[maxn]; ///h[i]=j表示i是j的异性
bool ok;

void inti(int n){
    ok=true;
    for(int i=0;i<=n;++i)
        f[i]=i,h[i]=0;
}

int find(int x){
    return f[x]!=x?(f[x]=find(f[x])):x;
}

void union_set(int x,int y){    //用并查集将同性的连接起来!!!!!! 
    x=find(x);   //x的祖先是什么性别 
    y=find(y);   //y的祖先是什么性别 
    if(x==y){   //同性说明错误 
        ok=false;
        return ;
    }
    if(h[x]) f[h[x]]=y;    //h[x]:之前匹配的x异性 ,  说明h[x]与y是同性,用并查集连接起来 
    if(h[y]) f[h[y]]=x;    //同理 
    h[x]=y; h[y]=x;       //x的异性是y。y的异性是x。 
}

int main(){
    int T; scanf("%d",&T);
    int cas=1;
    while(T--){
        int n,m; scanf("%d%d",&n,&m);
        inti(n);
        for(int i=0,a,b;i<m;++i){
            scanf("%d%d",&a,&b);
            if(!ok) continue;
            union_set(a,b);
        }
        printf("Scenario #%d:\n",cas++);
        if(ok)puts("No suspicious bugs found!");
        else puts("Suspicious bugs found!");
        puts("");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值