PAT 1114. Family Property (并查集)


总结了一下PAT的题目,我们要静下心来,耐心的实现每一个细节,代码实现起来比较不会出bug


并查集,我们可以一次一次完成,不要想着一部到位!!!



This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 ... Childk M_estate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi's are the ID's of his/her children; M_estateis the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000
给你n个关系,每一行包括: 此人的id,父亲的id,母亲的id,num个孩子,孩子的id,家产,土地面积


要你输出1.土地平均面积最大,2.一样的话,id升序排列


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<queue>
#include<map>
#include<cstring>
using namespace std;
const int N = 10000+100;
struct node
{
	int id;
	double num;
	double e,a;
}b[N],c[N];
bool cmp(node t1,node t2)
{
	if(t1.a/t1.num!=t2.a/t2.num) return t1.a/t1.num>t2.a/t2.num;
	else return t1.id<t2.id;
}
int fa[N],vis[N];

int find(int x)
{
	int r=x;
	while(fa[r]!=r) r=fa[r];
	int i=x,j;
	while(i!=r) {
		j=fa[i];
		fa[i]=r;
		i=j;
	}
	return r;
}

int main()
{
	int i,j,n,id,f,m,num,son,k;
	double a,e;
	int fx,fy;
	cin>>n;
	for(i=0;i<10000;i++) fa[i]=i;
	for(i=1;i<=n;i++) {
		cin>>id>>f>>m>>num;
		fx=find(id);
		b[id].num=1;
		b[id].id=id;
		if(f!=-1) {
			fy=find(f);
			if(fx!=fy) fa[fy]=fx;
			b[f].num=1;
			b[f].id=f;
		}
		if(m!=-1) {
			fy=find(m);
			if(fx!=fy) fa[fy]=fx;
			b[m].num=1;
			b[m].id=m;
		}
		while(num--) {
			cin>>son;
			fy=find(son);
			if(fx!=fy) fa[fy]=fx;
			b[son].num=1;
			b[son].id=son;
		}
		cin>>e>>a;
		b[id].a=a;
		b[id].e=e;
	}
	k=0;
	for(i=0;i<=10000;i++) {
		if(!b[i].num) continue;
		fx=find(i);
		if(i<fx) fa[fx]=i,fa[i]=i;
//		cout<<i<<" "<<b[fa[i]].id<<endl;
	}
	for(i=0;i<10000;i++) {
		if(i==find(i)) continue;
		else if(b[i].num) {
			b[find(i)].num++;
			b[find(i)].a+=b[i].a;
			b[find(i)].e+=b[i].e;
		}
	}
	for(i=0;i<10000;i++) {
		if(i==find(i) && b[i].num) {
			c[k].id=b[i].id;
			c[k].num=b[i].num;
			c[k].a=b[i].a;
			c[k++].e=b[i].e;
//			cout<<c[k-1].id<<" "<<c[k-1].num<<endl;
		}
	}

	sort(c,c+k,cmp);
	cout<<k<<endl;
	for(i=0;i<k;i++) printf("%04d %.0lf %.3lf %.3lf\n",c[i].id,c[i].num,c[i].e/c[i].num,c[i].a/c[i].num);

	return 0;
}












  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值