PAT 1105. Spiral Matrix (螺旋输出)


This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76

给你一段降序的序列,让你螺旋输出该序列

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int NN = 1e4+100;
int vis[NN][NN],a[NN][NN],b[NN]; 
int main()
{
	ios::sync_with_stdio(false);
	int N,i,j,n,m,k,flag;
	cin>>N;
	for(i=1;i<=N;i++) cin>>b[i];
	sort(b+1,b+1+N,greater<int>());
	for(i=1;i<=sqrt(N);i++) {
		if(N%i==0) m=i,n=N/i;
    }   
	for(i=1;i<=n;i++) vis[i][m+1]=1;
	for(i=1;i<=m;i++) vis[n+1][i]=1;
	for(i=1;i<=n;i++) vis[i][0]=1;
	k=0,flag=1,i=1,j=1;
	while(1) {
		a[i][j]=b[++k];
		if(k==N) break;
		vis[i][j]=1;
		if(flag==1) {
			if(vis[i][j+1]==0) j++;
			else flag=2,i++;
		}
		else if(flag==2) {
			if(vis[i+1][j]==0) i++;
			else flag=3,j--;
		}
		else if(flag==3) {
			if(vis[i][j-1]==0) j--;
			else i--,flag=4;
		}
		else {
			if(vis[i-1][j]==0) i--;
			else j++,flag=1;
		}
	}
	for(i=1;i<=n;i++) {
		for(j=1;j<=m;j++) {
			if(j!=1) cout<<" ";
			cout<<a[i][j];
		}
		cout<<endl;
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值