1109. Group Photo (模拟)


Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

  • The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;
  • All the people in the rear row must be no shorter than anyone standing in the front rows;
  • In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);
  • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);
  • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (<=10000), the total number of people, and K (<=10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:

For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:
10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159
Sample Output:
Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John


题意:高的站前排,每排站当前总人数/还剩几条队伍要排,如果有余数就要+1,每排的排列顺序是:最高的站中间,然后一次左右左边降序站人,

中间那个人,如果是偶数靠右。。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int N = 10000+100;
struct node
{
	int h;
	char name[11];
}a[N],c[N];

bool cmp(node t1,node t2)
{
	if(t1.h!=t2.h) return t1.h>t2.h;
	else if(strcmp(t1.name,t2.name)<0) return true;
	else return false;
}

void work(node b[],int n)
{
	int k=0;
	int p=n/2;
	int l=p-1,r=p+1;
	c[p]=b[k++];
	while(k<n) {
		c[l--]=b[k++];
		if(k>=n) break;
		c[r++]=b[k++];
	}
	for(int i=0;i<n;i++) {
		if(i) printf(" ");
		printf("%s",c[i].name);
	}
	printf("\n");
}



int main()
{
	int N,M,i,j,n,s;
	scanf("%d%d",&N,&M);
	for(i=0;i<N;i++) {
		scanf("%s%d",a[i].name,&a[i].h);
	}
	sort(a,a+N,cmp);
	s=0;
	for(i=M;i>0;i--) {
		n=N/i;
		if(N%i) n++;
		work(a+s,n);
		N-=n,s+=n;
	}
	return 0;
} 








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值