【坑、逻辑】1109 Group Photo (25 分)

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;

All the people in the rear row must be no shorter than anyone standing in the front rows;

In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);

In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.
Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (≤104), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).
Output Specification:

For each case, print the formation – that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:

10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159
结尾无空行

Sample Output:

Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John
结尾无空行

Wrong Code

#include <iostream>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;
typedef struct per{
	string name;
	int height;
}per;
bool cmp(per a, per b){
	return a.height != b.height ? a.height < b.height : a.name > b.name;
}
int main(){
	int n, k;
	int rest;
	cin>>n>>k;
	per p[10001];
	int res = n % k;//后面多出来的人
	vector<vector<string>> que(k, vector<string>(res)); 
	for(int i = 0; i < n; i++){
		string name;
		int height;
		cin>>p[i].name>>p[i].height;
	}
	sort(p, p + n, cmp);//从高到低排序 
	for(int i = 0; i < k; i++){
		int start = i * (n / k);//中开始取的位置 
		int cnt = (i == k - 1) ? (n / k) + res : n / k;//每一行的个数 
		for(int j = start; j < start + cnt; j++){
			que[i].push_back(p[j].name);
		}
	}
	for(int i = k - 1; i >= 0; i--){
		int t = que[i].size() - 1;
		for(int j = t - 1; j >= 1; j -= 2){
			cout<<que[i][j]<<" ";;
		}
		cout<<que[i][t];
		for(int j = t - 2; j >=1; j -= 2)
			cout<<" "<<que[i][j];
		cout<<endl;
	}
} 

liucuo

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
typedef struct node{
	string name;
	int height;
}node;
bool cmp(node a, node b){
	return a.height != b.height ? a.height > b.height : a.name < b.name;
}
int main(){
	int n, k, m;
	cin>>n>>k;
	vector<node> stu(n);//n位预定 
	for(int i = 0; i < n; i++)
		cin>>stu[i].name>>stu[i].height;
	sort(stu.begin(), stu.end(), cmp);
	int t = 0, row = k;//t表示该行开始位置在stu数组中的下标位置 
	while(row--){
		if(row == k)
			m = n - n / k * (k - 1);//m是最后一排,用总数减去前k-1排的
		else
			m = n / k;//否则就是正常
		vector<string> ans(m);//每一行的ans
		cout<<m<<endl;
		
		 int j = m / 2 - 1;//队伍中的左边
		 for(int i = t + 1; i < t + m; i += 2){
		 	ans[j--] = stu[i].name;
		 }
		 ans[m / 2] = stu[t].name;
		 j = m / 2 + 1;//队伍的右边
		 for(int i = t + 2; i < t + m; i += 2)
		 	ans[j++] = stu[i].name;
		for(int i = 0; i < m; i++){
			if(i == 0)
				cout<<ans[0];
			else
			cout<<" "<<ans[i];
		}	 
		cout<<endl;
		t += m;//开始位置t加上改行个数 
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_Amonlisa

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值