PAT甲级——1109 Group Photo (排序)

1109 Group Photo (25 分)

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

  • The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;

  • All the people in the rear row must be no shorter than anyone standing in the front rows;

  • In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);

  • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

  • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (≤10​4​​), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:

For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:

10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159

Sample Output:

Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John

题目大意:说是组队拍照,这里抽象一下,就是将N个人分成K行,除第一行外每行有N/K(向下取整)人,第一行是剩下的人数。要保证每一列从上到下身高递减,身高相同时按名字的字母顺序递增;每一行里,身高最高的在中间(人数除以2向上取整),第二名在他左边,第三名在他右边,按此规律左右递推。

思路:用struct存储人的姓名和身高,然后将信息存入数组 v 中,将 v 排序(使用algorithm里的排序函数,需要写个cmp函数自定义排序规则);对于每一行,截取 v 中对应的元素,例如第1行,对应v[0]~v[N-N/K*(K-1)],ans数组的中间元素的下标是half,从v[0]开始依次对ans数组的元素进行赋值,ans[half] = v[0]; ans[half-1] = v[1]; ans[half+1] = v[2]; ans[half-2] = v[3]……找出ans的下标计算的规律即可。

#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
using namespace std;
struct node {
	string name;
    int height;//最好是整型变量,不能用string,因为身高的位数不统一不便于比较
};
bool cmp(const node &a, const node &b) {
	return a.height != b.height ? a.height > b.height : a.name < b.name;
}
void print(vector <node> &v, int index, int n);
int main()
{
	int N, K, M, index = 0;
	scanf("%d%d", &N, &K);
	vector <node> v(N);
	for (int i = 0; i < N; i++)
		cin >> v[i].name >> v[i].height;
	sort(v.begin(), v.end(), cmp);
	int col = N / K;//除第一行外其他行的人数
	M = N - col * (K - 1);//第一行的人数
	for (int i = 0; i < K; i++) {
		if (i == 0) {
			print(v, index, M);
			index += M;
		}
		else {
			print(v, index, col);
			index += col;
		}
	}
	return 0;
}
void print(vector <node> &v, int index, int n) {
	vector <string> ans(n);
	int half = n / 2, j;
	for (int i = 0; i < n; i++) {
		if (i % 2 == 0) {
			j = half + i / 2;
			if (j < n) {
				ans[j] = v[index + i].name;
			}
		}
		else {
			j = half - (i + 1) / 2;
			if (j >= 0) {
				ans[j] = v[index + i].name;
			}
		}
	}
	for (int i = 0; i < n; i++) {
		cout << ans[i];
		if (i < n - 1)
			printf(" ");
	}
	printf("\n");
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值