POJ - 3279 Fliptile (暴力+二进制)


Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input
Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0




大意:一个m*n的01矩阵,每次点击(x,y),那么她的上下左右以及本身就会0变1,1变0,问把矩阵变成全0的,最小需要点击多少步。


想法:枚举第一行的所有可能,对于每种可能找出最优解。



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<string>
using namespace std;
const int N = 22;
int a[N][N],b[N][N],f[N][N];
int tmp,n,m;
int dx[]={-1,0,1,0,0};
int dy[]={0,1,0,-1,0};
bool check(int x,int y)
{
    int i,j,res;
    res=a[x][y];
    for(i=0;i<5;i++) {
        int tx = x+dx[i];
        int ty = y+dy[i];
        if(tx<0||tx>=n||ty<0||ty>=m) continue;
        res+=b[tx][ty];
    }
    if(res&1) return true;
    return false;
}
void work()
{
    int i,j;
    for(i=1;i<n;i++) {
        for(j=0;j<m;j++) {
            if(check(i-1,j)) {
                tmp++;
                b[i][j]=1;
            }
        }
    }
    for(i=0;i<m;i++) {
        if(check(n-1,i)) break;
    }
    if(i<m) tmp=N*N;
}
int main()
{
    int ans;
    int i,j,s,S;
    while(scanf("%d%d",&n,&m)!=EOF) {
        memset(f,0,sizeof(f));
        ans=N*N;
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
            scanf("%d",&a[i][j]);
        S=(1<<m);
        for(s=0;s<S;s++) {
            tmp=0;
            memset(b,0,sizeof(b));
            for(i=0;i<m;i++) {
                if(s&(1<<i)) {
                    tmp++;
                    b[0][i]=1;
                }
            }
            work();
            if(tmp>=ans) continue;
            ans=tmp;
            for(i=0;i<n;i++)
                for(j=0;j<m;j++)
                f[i][j]=b[i][j];
        }
        if(ans==N*N) printf("IMPOSSIBLE\n");
        else {
            for(i=0;i<n;i++) {
                for(j=0;j<m;j++) {
                    if(j) printf(" %d",f[i][j]);
                    else printf("%d",f[i][j]);
                }
                printf("\n");
            }
        }
    }
    return 0;
}









  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值