[kuangbin带你飞]专题1 简单搜索 D - Fliptile POJ - 3279

题目:

Fliptile
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 12927   Accepted: 4744

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate anM × N grid (1 ≤ M ≤ 15; 1 ≤N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0



题意:有一个M*N的网格,每个单位有两面,一面为白色(用0表示),另一面为黑色(用1表示)。反转一个单位时,它自己连同它的上下左右共5个单位都会发生变化。问若能使这个网格全变为白色朝上,需要怎样反转(输出的矩阵:1表示对对应的位置反转1次)。若不能则输出:“IMPOSSIBLE”。


思路:(1)由于在同一个位置连续两次反转 == 没有反转,则若要反转必只反转1次.

           (2)若想暴力枚举全部反转方法,则复杂度0(2^(M*N)).必然TLE。但是我们发现,若已经确定第一行的状态,则第二行为了让第一行的所有单位都变成白色,第二层的反转方法就确定了,这样的话第三层的反转也可以从第二层的状态确定下来……直到最后一层。若最后一层在把它上面那层全部变为白色后,它的反转方法能使它自己也变为白色,则这个方法就是一个合理的方法。由此,我们就可以枚举第一层的所有状态来确定整个网格的所有状态了。

           (3)利用二进制枚举第一层的所有反转情况,由此推出这个状态是否可行以及其反转次数,更新最小次数以及对应的ans数组。


类似题目:poj1222

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<stack>

typedef long long ll;

using namespace std;

int M,N;

int mapp[20][20];		  //输入的网格信息 
int temp[20][20];		  //处理操作所用的临时矩阵 

int status[20][20];		  //当前的反转操作 
int ans[20][20];          //存储最小反转次数对应的反转操作 

int minflip;              //存储最小的反转次数 

void flip(int i,int j){    //反转i,j对应的方格。其上下左右也要反转 
	temp[i][j] = !temp[i][j];
	temp[i-1][j] = !temp[i-1][j];
	temp[i+1][j] = !temp[i+1][j];
	temp[i][j-1] = !temp[i][j-1];
	temp[i][j+1] = !temp[i][j+1];
}

bool judge(){
	for(int i = 1 ; i<=M ; i++){
		for(int j = 1 ; j<=N ; j++){
			temp[i][j] = mapp[i][j];
		} 
	}
	 
	int tot = 0;//反转的次数 
	
	for(int j = 1 ; j<=N ; j++){
		if(status[1][j]){
			flip(1,j);
			tot++;
		}
	}
	for(int i = 2 ; i<=M ; i++){
		for(int j = 1 ; j<=N ; j++){
			if(temp[i-1][j]){         //若它头上的那个是黑色,则用它把它头上那个单位变成白色 
				flip(i,j);
				tot++;
				status[i][j] = 1;
			}
			else{
				status[i][j] = 0;
			} 
		}
	}
	
	for(int i = 1 ; i<=N ; i++){
		if(temp[M][i]==1){           //判断最后一行能否全部为白色,若有黑色则这个方法不正确,return false 
			return false;
		} 
	}
	
	if(minflip > tot){               //若方法可行,则判断次数与最小次数的关系,更新ans 
		minflip = tot;
		for(int i = 1 ; i<=M ; i++){
			for(int j =1 ; j<=N ; j++){
				ans[i][j] = status[i][j];
			}
		}
	}
	return true;
}

int main(){
	while(scanf("%d %d",&M , &N)!=EOF){
		for(int i = 1 ; i<=M ; i++){
			for(int j = 1 ; j<=N ; j++){
				scanf("%d",&mapp[i][j]);
			}
		}
		
		memset(status,0,sizeof(status));
		
		minflip = 1<<30;
		bool flag = 0;                  //是否有可行的操作 
		while (!status[1][N+1]){        //退出条件:status[1][N+1]==1.代表第一行1到n位置上所有状态都枚举过了 
			if(judge()){
				flag = 1;
			}
			
			status[1][1]++;                 //模拟二进制枚举所有状态 
			int c = 1;
			while (status[1][c]>1) {
				status[1][c] = 0;
				status[1][++c]++;
			}
		}
		
		if(!flag){
			printf("IMPOSSIBLE\n");
		}
		else{	
			for(int i = 1 ; i<=M ; i++){
				for(int j = 1 ; j<=N ; j++){
					if(j==1)
						printf("%d",ans[i][j]);
					else{
						printf(" %d",ans[i][j]);
					}
				}
				printf("\n");
			}
		}
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值