Candy Sharing Game

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy. 
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with. 
InputThe input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself. 
OutputFor each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line. 
Sample Input
6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0
Sample Output
15 14
17 22
4 8


        
  
Hint
The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.


题解:题意就是老师吹哨的时候,所有同学同时把自己手里的糖果的一半给右边的同学,手里糖果数是奇数的同学将从老师手里获得一个糖果以凑成整数,求使所有同学手中糖果数目一致需要多少次; 所以构建数组进行模拟就行,注意过程中的细节。

代码:

#include <stdio.h>
#include <stdlib.h>


int main()
{
    int n,a[10001],b[10001];
    int i,sum,f; //f用来判断所有同学手中的糖果数目是否一致;
    while(scanf("%d",&n) && n){
         for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
            f=1;
            sum=0;
         while(f){
            sum++;
            for(i=1;i<=n;i++)
                b[i]=a[i];
            for(i=2;i<=n;i++){
                a[i]=b[i]/2+b[i-1]/2;
                if(a[i]%2==1) a[i]+=1;
            }
            a[1]=b[1]/2+b[n]/2;
            if(a[1]%2==1) a[1]+=1;
            f=0;
            for(i=1;i<n;i++)
                if(a[i]!=a[i+1]) f=1;
         }
         printf("%d %d\n",sum,a[i]);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值