Number Sequence

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

 

题解:简单的kmp

代码:

#include <iostream>

using namespace std;

int str[1000050],temp[10050],fail[10050];

void getFail(int n) {		         	//n表示短字符串的长度
  int i = 0, j = -1;			        //i表示短字符串当前位置,j表示当前位置之前的部分前缀和后缀相同的个数-1
	fail[0] = -1;		        		//fail数组表示当前位置匹配失败后从短字符串之前哪个位置继续匹配
	while(i < n) {
		if(j==-1 || temp[i]==temp[j])	//temp数组用来存储短字符串
		{
			++i, ++j;
			if(temp[i] != temp[j]) fail[i] = j;
			else fail[i] = fail[j];
		}
		else j = fail[j];
	}
}

int kmp(int n, int m) {				//n表示长字符串的长度,m表示短字符串的长度
	int i = 0, j = 0;					//i表示长字符串当前位置,j表示短字符串当前位置
	while(i < n) {
		if(j==-1 || str[i]==temp[j]) {	//temp存储短字符串,str存储长字符串
			++i, ++j;
			if(j == m) {				//当发现长字符串中有一个短字符串时
				return i-m+1;
				j = 0;
			}
		}
		else j = fail[j];
	}
	return -1;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int m,n;
        cin>>m>>n;
        for(int i=0;i<m;i++)
            cin>>str[i];
        for(int i=0;i<n;i++)
            cin>>temp[i];
        getFail(n);
        cout<<kmp(m,n)<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值