Seek the Name, Seek the Fame

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 

 

题解:kmp算法中前缀数组得简单运用;

 

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char temp[400050];
int fail[400050];
void getFail(int n) {					//n表示短字符串的长度
    int i = 0, j = -1;						//i表示短字符串当前位置,j表示当前位置之前的部分前缀和后缀相同的个数-1
	fail[0] = -1;							//fail数组表示当前位置匹配失败后从短字符串之前哪个位置继续匹配
	while(i < n) {
		if(j==-1 || temp[i]==temp[j])		//temp数组用来存储短字符串
		{
			++i, ++j;
			fail[i] = j;
		}
		else j = fail[j];
	}
}
int main()
{
    int d[400050];
    while(scanf("%s",temp)!=EOF)
    {
        int n=strlen(temp);
        getFail(n);
        int ans=0;
        for(int i=n; fail[i]!=-1; i=fail[i])
              d[ans++]=i;
        cout<<d[ans-1];
        for(int i=ans-2; i>=0; i--)
        printf(" %d",d[i]);
        cout<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值