尺取法

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

题解:维护前缀和,排序后尺取;

#include <iostream>
#include <algorithm>
using namespace std;

#define inf 0x3f3f3f3f
struct node
{
    int sum;
    int id;
}a[100050];
bool cmp(node x, node y)
{
    return x.sum<y.sum;
}
int main()
{
    int n,k;
    int ans,la,ra;
    while(cin>>n>>k && ( n || k ))
    {
        a[0].sum=0;
        a[0].id=0;
        int x;
        for(int i=1; i<=n; i++)
        {
            cin>>x;
            a[i].id=i;
            a[i].sum=a[i-1].sum+x;
        }
        sort(a,a+n+1,cmp);
        while(k--)
        {
            int t;
            cin>>t;
            int left=0, right=1;
            int res=inf;
            while(right<=n)
            {
				int y=a[right].sum-a[left].sum;
				if (abs(y-t)<res)
				{
				    res=abs(y-t);
					la=min( a[left].id, a[right].id );
					ra=max( a[left].id, a[right].id );
					ans=y;
				}
				if (y<t)
					right++;
				else if (y>t)
					left++;
				else
					break;
				if (left==right)
					right++;
            }
            la++;
            cout<<ans<<" "<<la<<" "<<ra<<endl;
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值