线段树区间更改区间查询

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

题解:线段树的区间修改求和模板题,挺简单的;

#include <iostream>
#include <cstdio>
using namespace std;
typedef long long ll;
const int maxn = 1e5 + 7;
int n, m, l, r;
char opt;
ll a[maxn], x;
struct seg
{
    int l,r;
    ll sum,tag;
} tree[maxn<<2];
void build(int p, int l, int r)
{
    tree[p].l = l;
    tree[p].r = r;
    tree[p].sum = tree[p].tag = 0;
    if(l == r)
    {
        tree[p].sum = a[l];
        return;
    }
    int mid = (l + r) >> 1;
    build(p<<1, l, mid), build(p<<1|1, mid+1, r);
    tree[p].sum = tree[p<<1].sum + tree[p<<1|1].sum;
}//建树;
void push_down(int p)
{
    if(tree[p].tag)
    {
        tree[p<<1].sum += 1LL*(tree[p<<1].r - tree[p<<1].l + 1)*tree[p].tag;
        tree[p<<1|1].sum += 1LL*(tree[p<<1|1].r - tree[p<<1|1].l + 1)*tree[p].tag;
        tree[p<<1].tag += tree[p].tag;
        tree[p<<1|1].tag += tree[p].tag;
        tree[p].tag = 0;
    }
}
void add(int p, int l, int r, ll x)
{
    if(tree[p].l == l && tree[p].r ==r)
    {
        tree[p].sum += 1LL*(r-l+1)*x;
        tree[p].tag += x;
        return;
    }
    int mid = (tree[p].l + tree[p].r) >> 1;
    push_down(p);
    if(r <= mid) add(p<<1, l, r, x);
    else if(l > mid) add(p<<1|1, l, r, x);
    else add(p<<1, l, mid, x), add(p<<1|1, mid+1, r, x);
    tree[p].sum = tree[p<<1].sum + tree[p<<1|1].sum;
}
ll ask_sum(int p, int l, int r)
{
    if(tree[p].l == l && tree[p].r == r) return tree[p].sum;
    push_down(p);
    int mid = (tree[p].l + tree[p].r) >> 1;
    if(r <= mid) return ask_sum(p<<1, l, r);
    else if(l > mid) return ask_sum(p<<1|1, l, r);
    else return ask_sum(p<<1, l, mid) + ask_sum(p<<1|1, mid+1, r);
}
int main()
{
    scanf("%d%d", &n, &m);
    for(int i = 1; i <= n; i++)
        cin>>a[i];
    build(1, 1, n);
    for(int i = 1; i <= m; ++i)
    {
        getchar();
        scanf("%c%d%d", &opt, &l, &r);
        if(opt == 'Q') {//sum
            cout<<ask_sum(1, l, r)<<endl;
        }
        else if(opt=='C'){// add
            cin>>x;
            add(1, l, r, x);
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值