【算法】算法之美—Jugs

题目概述:Jugs


   In the movie "Die Hard 3", Bruce Willis and Samuel L. Jackson were confronted with the following puzzle. They were given a 3-gallon jug and a 5-gallon jug and were asked to fill the 5-gallon jug with exactly 4 gallons. This problem generalizes that puzzle.


   You have two jugs, A and B, and an infinite supply of water. There are three types of actions that you can use:

    • you can fill a jug,

    • you can empty a jug

    • you can pour from one jug to the other. Pouring from one jug to the other stops when the first jug is empty or the second jug is full, whichever comes first.


   For example, if A has 5 gallons and B has 6 gallons and a capacity of 8, then pouring from A to B leaves B full and 3 gallons in A.


   A problem is given by a triple (Ca,Cb,N), where Ca and Cb are the capacities of the jugs A and B, respectively, and N is the goal. A solution is a sequence of steps that leaves exactly N gallons in jug B. The possible steps are


    • fill A

    • fill B

    • empty A

    • empty B

    • pour A B

    • pour B A

    • success


   where "pour A B" means "pour the contents of jug A into jug B", and "success" means that the goal has been accomplished.

   You may assume that the input you are given does have a solution.


Input


   Input to your program consists of a series of input lines each defining one puzzle. Input for each puzzle is a single line of three positive integers: Ca, Cb, and N. Ca and Cb are the capacities of jugs A and B, and N is the goal. You can assume 0 < Ca <= Cb and N <= Cb <=1000 and that A and B are relatively prime to one another.


Output


   Output from your program will consist of a series of instructions from the list of the potential output lines which will result in either of the jugs containing exactly N gallons of water. The last line of output for each puzzle should be the line "success". Output lines start in column 1 and there should be no empty lines nor any trailing spaces.


Sample Input


    • 3 5 4

    • 5 7 3


Sample Output


    • fill B

    • pour B A

    • empty A

    • pour B A

    • fill B

    • pour B A

    • success

    • fill A

    • pour A B

    • fill A

    • pour A B

    • empty B

    • pour A B

    • success



简单描述


   题目意思还是比较简单,简单概述一下就是:有无限的水和两个水桶,一个容量 ca升,一个容量 cb升,问怎么用两个桶得到 n升水,要求比较简单,就不复述了。



题目分析


   简单分析下此题目:

    1. 两个水桶 A和B,则需要两个变量来表示其容量,设为 ca和cb

    2. 目标变量 n

    3. 水在倒的过程中,两个水桶的当前水量会发生变化,需要两个变量表示当前量,设为 x和y

    4. 目标量可能由 A得到,也可能由 B得到,所以需要对 A和B进行判断  



解题算法


   注释丰富,就不多说了

#include < stdio.h>
int main()
{
    int ca,cb,n,x,y;
    /* Ca, Cb, and N. Ca and Cb are the capacities of jugs A and B, and N is the goal.
     * 即:ca为 A的容量,cb为 B的容量,N为要得到的水
     * x为 ca当前已有的水
     * y为 cb当前已有的水
     */
    while( scanf("%d %d %d",&ca,&cb,&n)!=EOF)
    {
        x=y=0;
        while(1)
        {
            printf("fill A\n");
            x=ca;
            if(x==n)    /* 如果 A得到目标 */
            {
                printf("success\n");
                break;  /* 成功,退出循环 */
            }
            while(x>0)
            {
                if((cb-y)>=x)    /* B能够容纳的水 > A当前的水 */
                {
                    printf("pour A B\n");   /* 则将 A中的水全部倒入 B中 */
                    y=y+x;  /* y增加 x升水 */
                    x=0;
                }
                else
                {
                    printf("pour A B\n");
                    x=x-(cb-y); /* A中还剩有水 */
                    y=cb;   /* B中装满 */
                }
                if(x==n)    /* A得到目标 */
                {
                    printf("success\n");
                    break;
                }
                if(y==n)    /* B得到目标 */
                    break;
                if(y==cb)   /* B空 */
                {
                    printf("empty B\n");
                    y=0;
                }
            }
            if(x==n)
                break;
            if(y==n)
            {
                printf("success\n");
                break;
            }
        }
    }
    return 0;
}



本文出自 “成鹏致远” 博客,请务必保留此出处http://infohacker.blog.51cto.com/6751239/1230301

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值