hdu 1113 Word Amalgamation

题目地址:

http://acm.hdu.edu.cn/showproblem.php?pid=1113

题目描述:

Word Amalgamation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2331    Accepted Submission(s): 1102


Problem Description
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words. 
 

Input
The input contains four parts: 

1. a dictionary, which consists of at least one and at most 100 words, one per line; 
2. a line containing XXXXXX, which signals the end of the dictionary; 
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and 
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique. 
 

Output
For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.
 

Sample Input
  
  
tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX
 

Sample Output
  
  
score ****** refund ****** part tarp trap ****** NOT A VALID WORD ****** course ******

题意:

将用户输入的单词中 有完全相同单词组成的 输出字典中的单词,并要按字典序输出。

题解:

将字典先按字典序将单词排序,然后再将每个单词按字母序 再排序,然后对用户输入的单词,也进行字母序排序,对照二次排序后的字典,相同的直接输出字典原单词。

错因:

STL sort函数 不能简单的sort二维字符串 ,要么它的下级结构 是一个结构体  或是 string类型的字符串,详见转载博客。

代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
char DicStr[100+5][10+5];//the dictinary
char MapStr[100+5][10+5];//the dictionary map string list
int DicLen=0;//the count of the words
char word[10+5]={'\0'};
/*for test*/
int test()
{
	return(0);
}
/*resort the per word*/
int ReSortStr()
{
	int i=0;
	for(i=0;i<=DicLen-1;i++)
	{
		char ReWord[10+5];
		strcpy(ReWord,DicStr[i]);
		sort(ReWord,ReWord+strlen(ReWord));
		strcpy(MapStr[i],ReWord);
	}
	return(0);
}
/*compare for the sort*/
bool cmp(char *a,char *b)
{
	if(strcmp(a,b)<0)
	{
		return(true);
	}
	else
	{
		return(false);
	}
}
/*compare for the qsort*/
int qcmp(const void *a,const void *b)
{
	char * A=(char *)a;
	char * B=(char *)b;
	if(strcmp(A,B)<0)
	{
		return(-1);
	}
	else if(strcmp(A,B)>0)
	{
		return(1);
	}
	else
	{
		return(0);
	}
}
/*main process*/
int MainProc()
{
	//input the dictionary
	DicLen=0;
	while(scanf("%s",word)!=EOF&&strcmp(word,"XXXXXX")!=0)
	{
		strcpy(DicStr[DicLen],word);
		DicLen++;
	}
	//predeal the DicStr and the MapStr
	//sort(&DicStr[0],&DicStr[0]+DicLen,cmp);//how to use two-dimension array to sort it's word,read the reprinted blog
	//qsort(DicStr,DicLen,sizeof(DicStr[0]),qcmp);
	ReSortStr();//resort the per word;
	while(scanf("%s",word)!=EOF&&strcmp(word,"XXXXXX")!=0)
	{
		sort(word,word+strlen(word));
		int i=0,flag=0;
		for(i=0;i<=DicLen-1;i++)
		{
			if(strcmp(word,MapStr[i])==0)
			{
				flag=1;
				printf("%s\n",DicStr[i]);
			}
		}
		if(!flag)
		{
			printf("NOT A VALID WORD\n");
		}
		printf("******\n");
	}
	return(0);
}
int main()
{
	MainProc();
	return(0);
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值