hdu 1393 Weird Clock

题目地址:

http://acm.hdu.edu.cn/showproblem.php?pid=1393

题目描述:

Weird Clock

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2639    Accepted Submission(s): 945


Problem Description
A weird clock marked from 0 to 59 has only a minute hand. It won't move until a special coin is thrown into its box. There are different kinds of coins as your options. However once you make your choice, you cannot use any other kind. There are infinite number of coins of each kind, each marked with a number d ( 1 <= d <= 1000 ), meaning that this coin will make the minute hand move d times clockwise the current time. For example, if the current time is 45, and d = 2. Then the minute hand will move clockwise 90 minutes and will be pointing to 15.

Now you are given the initial time s ( 1 <= s <= 59 ) and the coin's type d. Write a program to find the minimum number of d-coins needed to turn the minute hand back to 0.
 

Input
There are several tests. Each test occupies a line containing two positive integers s and d.

The input is finished by a line containing 0 0.
 

Output
For each test print in a single line the minimum number of coins needed. If it is impossible to turn the hand back to 0, output "Impossible".
 

Sample Input
  
  
30 1 0 0
 

Sample Output
  
  
1

题意:

判断最短转几个d次能刚好到60刻钟。

题解:

模拟,并用了索引思想,重复了不是60的刻钟 永远到不了60.

代码:

#include<stdio.h>
#include<string.h>
bool visited[61] = {false};
int s=0,d=0;
int main()
{
    while(scanf("%d%d",&s,&d)!=EOF&&(s+d)>0)
    {
        memset(visited,false,sizeof(visited));
        visited[60]=true;
        visited[s]=true;
        int cnt=0;
        while(s != 60)
        {
            s=s+s*d;
            cnt++;
            while(s>60) s-=60;
            if(visited[s]) break;
            else visited[s] = true;
        }
        if(s==60) printf("%d\n",cnt);
        else printf("Impossible\n");
    }
    return(0);
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值