hdu 1390 Binary Numbers

题目地址:

http://acm.hdu.edu.cn/showproblem.php?pid=1390

题目描述:

Binary Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2834    Accepted Submission(s): 1758


Problem Description
Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0.


Example

The positions of 1's in the binary representation of 13 are 0, 2, 3.


Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1's in the binary representation of n,

writes the result.
 

Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
 

Output
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.
 

Sample Input
  
  
1 13
 

Sample Output
  
  
0 2 3

题意:
输出2进制数位为1的位置,从低到高。

题解:

这题主要注意两点:
1、二进制的低位高位问题(与10进制是de一样),11110000;1是高位,0是低位
2、注意格式问题,第一个余数为1的输出 "%d" ,其余后序余数为1的输出 " %d"

代码:
#include<stdio.h>
int d=0,n=0;
int main()
{
    while(scanf("%d",&d)!=EOF)
    {
        while(d--)
        {
           scanf("%d",&n);
           int ind=0;
           while(n>0)
           {
               if(n%2==1)
               {
                   printf("%d",ind);
                   ind++;
                   n/=2;
                   break;
               }
               ind++;
               n/=2;
           }
           while(n>0)
           {
               if(n%2==1) printf(" %d",ind);
               ind++;
               n/=2;
           }
           printf("\n");
        }
    }
    return(0);
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值