二分匹配最大独立集——hdu1068

hdu1068:http://acm.hdu.edu.cn/showproblem.php?pid=1068

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9414    Accepted Submission(s): 4295


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
  
  
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
  
  
5 2
题意:有n个学生(0~n-1),下面n行代表同学a与后面的m个同学有暧昧关系。有一个集合,满足:里面的同学两两之间没有暧昧关系,求这个集合中做多的同学数量。

思路:这个题求的就是二分匹配的最大独立集(若途中有m个点,则选出n个点,这n个点满足任意两个点之间没有边相连),,,然而,这个题任性的是,没有给出哪些有关系的同学之间哪个是男生,哪个是女生。。。。。因此需要吧一个同学拆分成一个男生,一个女生,然后求出最大匹配数。。。用总人数 - 最大匹配数 / 2  就是答案。

补充:二分图最大独立集=顶点数-二分图最大匹配

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<string>
#include<stack>
using namespace std;

typedef long long LL;
const int maxn=1000 + 10;
int n,m,k;
int g[maxn][maxn],vis[maxn],link[maxn];

bool path(int u)
{
    for(int i = 0; i < k; i++)
    {
        if(g[u][i] && !vis[i])
        {
            vis[i] = 1;
            if(link[i] == -1 || path(link[i]))
            {
                link[i] = u;
                return true;
            }
        }
    }
    return false;
}
int dfs()
{
    int res = 0;
    memset(link,-1,sizeof(link));
    for(int i = 0; i < k; i++)
    {
        memset(vis,0,sizeof(vis));
        if(path(i))res ++;
    }
    return res;
}
int main()
{
//    freopen("in.txt","r",stdin);
    while(~scanf("%d",&k) && k)
    {
        memset(g,0,sizeof(g));
        for(int p = 0; p < k; p++)
        {
            int a,b;
            scanf("%d: (%d)",&a,&m);
            for(int i = 0; i < m; i++)
            {
                scanf("%d",&b);
                g[a][b] = 1;
            }
        }
        int ans = dfs();
        printf("%d\n",k - (ans / 2));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值