poj2771——二分最大独立集

poj2771Guardian of Decency:http://poj.org/problem?id=2771

Guardian of Decency
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 5343 Accepted: 2242

Description

Frank N. Stein is a very conservative high-school teacher. He wants to take some of his students on an excursion, but he is afraid that some of them might become couples. While you can never exclude this possibility, he has made some rules that he thinks indicates a low probability two persons will become a couple: 
  • Their height differs by more than 40 cm. 
  • They are of the same sex. 
  • Their preferred music style is different. 
  • Their favourite sport is the same (they are likely to be fans of different teams and that would result in fighting).

So, for any two persons that he brings on the excursion, they must satisfy at least one of the requirements above. Help him find the maximum number of persons he can take, given their vital information. 

Input

The first line of the input consists of an integer T ≤ 100 giving the number of test cases. The first line of each test case consists of an integer N ≤ 500 giving the number of pupils. Next there will be one line for each pupil consisting of four space-separated data items: 
  • an integer h giving the height in cm; 
  • a character 'F' for female or 'M' for male; 
  • a string describing the preferred music style; 
  • a string with the name of the favourite sport.

No string in the input will contain more than 100 characters, nor will any string contain any whitespace. 

Output

For each test case in the input there should be one line with an integer giving the maximum number of eligible pupils.

Sample Input

2
4
35 M classicism programming
0 M baroque skiing
43 M baroque chess
30 F baroque soccer
8
27 M romance programming
194 F baroque programming
67 M baroque ping-pong
51 M classicism programming
80 M classicism Paintball
35 M baroque ping-pong
39 F romance ping-pong
110 M romance Paintball

Sample Output

3
7
题意:老师腰带同学出去玩,但是担心这些同学中有情侣,老师不想带情侣出去于是他判断满足下列至少一个条件就不是情侣:1、身高差超过40cm.2、性别相同.3、喜欢的音乐不同.4、喜欢的题意相同。

思路:将满足任意条件的学生排除,剩下的两两之间建立连接。(这题还是比较裸的独立集

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cstdlib>
#include<string>
#include<stack>
using namespace std;


const int maxn=500 + 10;
int n,m;
int g[maxn][maxn],vis[maxn],link[maxn];

struct Node
{
    int height;
    char sex[10];
    char music[110];
    char sport[110];
} student[maxn];

bool path(int u)
{
    for(int i = 0; i < n; i++)
    {
        if(g[u][i] && !vis[i])
        {
            vis[i] = 1;
            if(link[i] == -1 || path(link[i]))
            {
                link[i] = u;
                return true;
            }
        }
    }
    return false;
}
int dfs()
{
    int ans = 0;
    memset(link,-1,sizeof(link));
    for(int i = 0; i < n; i++)
    {
        memset(vis,0,sizeof(vis));
        if(path(i))ans ++;
    }
    return ans;
}
int main()
{
//    freopen("in.txt","r",stdin);
    int t;
    scanf("%d",&t);
    while(t --)
    {
        memset(g,0,sizeof(g));
        scanf("%d",&n);
        for(int i = 0; i < n; i++)scanf("%d%s%s%s",&student[i].height,student[i].sex,student[i].music,student[i].sport);
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < n; j++)
            {
                if(i == j)continue;
                if(abs(student[i].height - student[j].height) > 40)continue;
                else if(strcmp(student[i].sex,student[j].sex) == 0)continue;
                else if(strcmp(student[i].music,student[j].music) != 0)continue;
                else if(strcmp(student[i].sport,student[j].sport) == 0)continue;
                g[i][j] = 1;
            }
        }
        int ans = dfs();
        printf("%d\n",n - ans / 2);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值