hdu 1003 Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26441    Accepted Submission(s): 5582

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

 

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 

 

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

题解:

这道题用动态规划,解题思路来自别人

以下是变量说明:

t 测试数据组数

n 每组数据的长度

temp 当前取的数据

pos1 最后MAX SUM的起始位置

pos2 最后MAX SUM的结束位置

max 当前得到的MAX SUM

now 在读入数据时,能够达到的最大和x 记录最大和的起始位置,因为不知道跟之前的max值的大小比,所以先存起来下面模拟过程:

1.首先,读取第一个数据,令now和max等于第一个数据,初始化pos1,pos2,x位置2.然后,读入第二个数据,判断①. 若是now+temp<temp,表示当前读入的数据比之前存储的加上当前的还大,说明可以在当前另外开始记录,更新now=temp②. 反之,则表示之前的数据和在增大,更新now=now+temp3.之后,把now跟max做比较,更新或者不更新max的值,记录起始、末了位置4.循环2~3步骤,直至读取数据完毕。

#include<stdio.h>
int main()
{
	int i,j,t,pos1,pos2,x,temp,n,count=1,now,max,m;
	scanf("%d",&t);
	m=t;
	while(t--)
	{
		scanf("%d",&n);
	    scanf("%d",&temp);
		now=temp;
		max=temp;
		pos1=1;
		pos2=1;
		x=1;
		for(j=2;j<=n;j++)
		{
			scanf("%d",&temp);
			if(now+temp<temp)
			{
				now=temp;
				x=j;
			}
			else
				now+=temp;
			if(now>max)
			{
				max=now;pos1=x;pos2=j;
			}
		}
		printf("Case %d:\n",count++);
		printf("%d %d %d\n",max,pos1,pos2);
		if(count!=m+1) printf("\n");
	}
	return 0;
}
		


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值