1.g Duizi and Shunzi

Nike likes playing cards and makes a problem of it. 

Now give you n integers,  ai(1in)ai(1≤i≤n) 

We define two identical numbers (eg:  2,22,2) a Duizi, 
and three consecutive positive integers (eg:  2,3,42,3,4) a Shunzi. 

Now you want to use these integers to form Shunzi and Duizi as many as possible. 

Let s be the total number of the Shunzi and the Duizi you formed. 

Try to calculate  max(s)max(s)

Each number can be used only once. 
InputThe input contains several test cases. 

For each test case, the first line contains one integer n( 1n1061≤n≤106). 
Then the next line contains n space-separated integers  aiai ( 1ain1≤ai≤n
OutputFor each test case, output the answer in a line. 
Sample Input
7
1 2 3 4 5 6 7
9
1 1 1 2 2 2 3 3 3
6
2 2 3 3 3 3 
6
1 2 3 3 4 5
Sample Output
2
4
3
2


        
  
Hint
Case 1(1,2,3)(4,5,6)

Case 2(1,2,3)(1,1)(2,2)(3,3)

Case 3(2,2)(3,3)(3,3)

Case 4(1,2,3)(3,4,5)


思路:要找出来顺子和对子,先找顺子或先找对子的方法都不合适,用贪心法,先找顺子,再看顺子的前两个数能不能构成对子,

//#include<bits/stdc++.h>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int book[1000000];

int main(void){
    int n,i,a,maxn;
    while(~scanf("%d",&n)){
         memset(book,0,sizeof(book));//注意要在循环内
         int maxn=-1;//节省贪心模拟的时间
        for(i=1;i<=n;i++){
            scanf("%d",&a);
            book[a]++;  //统计出来每个数出现的次数,方便找对子
            maxn=max(maxn,a);
        }
        int res=0;  //注意要在循环内
        for(i=3;i<=maxn+3;i++){
            if(book[i-1]>=2){   //看顺子的第二个数有没有对子
                if(book[i-1]%2==0){
                    res+=book[i-1]/2;
                    book[i-1]=0;
                }
                else if(book[i-1]%2){
                    res+=book[i-1]/2;
                    book[i-1]=1;
                }
            }
            if(book[i-2]>=2){   //看顺子的第一个数有没有对子
                if(book[i-2]%2==0){
                    res+=book[i-2]/2;
                    book[i-2]=0;
                }
                else if(book[i-2]%2){
                    res+=book[i-2]/2;
                    book[i-2]=1;
                }
            }
            if(book[i]&&book[i-1]&&book[i-2]){   //顺子
                book[i]--;
                book[i-1]--;
                book[i-2]--;
                res++;
            }

        }
        printf("%d\n",res);

    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值