1023 Have Fun with Numbers (20分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.
Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.
Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.
Sample Input:

1234567899

Sample Output:

Yes
2469135798

题意:输入一个数字记录各个位数字出现的次数,然后将这个数字乘以2,在统计各个位数字出现的次数。如果出现次数相等,则输出Yes,否则输出No,接着换行输出2倍的数字
注意:题目要求数字位数不大于20位,有可能超过longlong的数据范围,所以我们要用大整数表示,以及大整数加法

AC代码

#include<stdio.h>
#include<string.h>
struct bign{//大整数定义
	int d[30];
	int len;
	bign(){
		memset(d,0,sizeof(d));
		len=0;
	}
};
int a1[10]={0};//hash计数
int b1[10]={0};
bign change(char str[]){//str向bign转换
	bign temp;
	temp.len=strlen(str);
    int num=0;
	for(int i=temp.len-1;i>=0;i--){
		temp.d[num++]=str[i]-'0';
	}
	return temp;
}
bign add(bign temp){//两数相加
	int carry=0;//进位
	bign c;
	for(int i=0;i<temp.len;i++){
		int flag=temp.d[i]+temp.d[i]+carry;
		carry=flag/10;
		c.d[c.len++]=flag%10;
	}
	if(carry!=0){
		c.d[c.len++]=carry;	
	}
	return c;
}
bool judge(bign a,bign b){
	for(int i=0;i<a.len;i++){
		a1[a.d[i]]++;
	}
	for(int i=0;i<b.len;i++){
		b1[b.d[i]]++;
	}
	for(int i=0;i<10;i++){
		if(a1[i]!=b1[i]){
			return false;
		}
	}
	return true;
}
void print(bign temp){
	for(int i=temp.len-1;i>=0;i--){
		printf("%d",temp.d[i]);
	}
	printf("\n");
}
int main(){
	char str[30];
	scanf("%s",str);
	bign a=change(str);
	bign b=add(a);
	if(judge(a,b)==true){
		printf("Yes\n");
		print(b);
	}else{
		printf("No\n");
		print(b);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值