1051 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

题意:模拟一个栈的出栈与入栈,判断出栈顺序的对错
思路:一旦这个栈超出了容量就证明了一定是错误的,只需要在入栈的同时判断是否超出容量即可。另设一个变量cur从1开始,一旦st.top()==arr[cur]那么就将它出栈,cur++,因为出栈的第一个必定是第一个出栈的,只需要不断判断栈顶就可以了。

AC代码

#include<stdio.h>
#include<stack>
using namespace std;
stack<int>st;
int main(){
	int n,t,m;
	int arr[1010];
	scanf("%d%d%d",&m,&n,&t);
	while(t--){
		for(int i=1;i<=n;i++){
			scanf("%d",&arr[i]);//出栈顺序
		}
		while(!st.empty()){//注意完成一组数据后要清空
			st.pop();
		}
		int cur=1;//进行出栈数组的移动
		bool flag=true;//是否正确 
		for(int i=1;i<=n;i++){
			st.push(i);
			if(st.size()>m){
				flag=false;
				break;
			}
			while(!st.empty()&&st.top()==arr[cur]){//判断是否出栈
				st.pop();//1 2 3 4 5 6 7
				cur++;//5 6 4 3 7 2 1
			}
		}
		if(st.empty()==true&&flag==true){
			printf("YES\n");
		}else{
			printf("NO\n");
		}
	}
	
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值