1107 Social Clusters (30分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.
Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] … h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].
Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

题意:有n个同学,每个同学有k个兴趣爱好,如果两个同学兴趣爱好相同,则称他们为有联系。现给出n个同学,求可以构成的联系个数,以及每个联系网络拥有的人数

思路:运用并查集进行统计(初始化,寻找根节点,合并),注意联系是通过兴趣进行的,另开设一个数组存放爱好

#include<stdio.h>
#include<algorithm>
using namespace std;
const int maxn=1010;
int father[maxn];
bool isroot[maxn];//计数几个联系网络
int number[maxn]={0};
int course[maxn]={0};
bool cmp(int a,int b){//排序
	return a>b;
}
void init(int n){//初始化并查集
	for(int i=1;i<=n;i++){
		isroot[i]=true;//起始全部为独立网络
		father[i]=i;
	}
}
int find_father(int x){
	while(x!=father[x]){
		isroot[x]=false;//成为孩子
		x=father[x];
	}
	return x;
}
void Union(int a,int b){
	int fa=find_father(a);//合并网络
	int fb=find_father(b);
	if(fa!=fb){
		isroot[fb]=false;
		father[fb]=fa;
	}
}
int main(){
	int n,k;
	scanf("%d",&n);
  	init(n);
	for(int i=1;i<=n;i++){
		scanf("%d:",&k);
		for(int j=1;j<=k;j++){
			int m;
			scanf("%d",&m);
			if(course[m]==0){//i的喜好为m
				course[m]=i;
			}
			Union(i,course[m]);//合并,依据喜好合并
		}
	}
	int ans=0;
	for(int i=1;i<=n;i++){
		number[find_father(i)]++;
		if(isroot[i]==true){
			ans++;
		}
	}
	printf("%d\n",ans);
	sort(number+1,number+1+n,cmp);
	for(int i=1;i<=n;i++){
		if(number[i]!=0){
			ans--;
			if(ans>0){
				printf("%d ",number[i]);
			}else{
				printf("%d\n",number[i]);
			}
		}
	}	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
非常抱歉,我的回答里有误,`clusters.erase`应该改为`clusters.erase(clusters.begin() + minCluster2)`。这是因为 `clusters` 是一个 `vector`,我们需要使用 `vector` 的 `erase` 函数来删除其中的元素。 完整的代码如下: ```c++ #include <iostream> #include <vector> #include <cmath> #include <limits> using namespace std; struct DataPoint { double value; int cluster; }; double getDistance(const DataPoint& p1, const DataPoint& p2) { return fabs(p1.value - p2.value); } void mergeClusters(vector<DataPoint>& data, int cluster1, int cluster2) { for (auto& point : data) { if (point.cluster == cluster2) { point.cluster = cluster1; } } } void hierarchicalClustering(vector<DataPoint>& data) { int n = data.size(); vector<int> clusters(n); for (int i = 0; i < n; ++i) { clusters[i] = i; } while (n > 1) { double minDist = numeric_limits<double>::max(); int minCluster1 = -1, minCluster2 = -1; for (int i = 0; i < n-1; ++i) { for (int j = i+1; j < n; ++j) { double dist = getDistance(data[i], data[j]); if (dist < minDist) { minDist = dist; minCluster1 = clusters[i]; minCluster2 = clusters[j]; } } } mergeClusters(data, minCluster1, minCluster2); clusters.erase(clusters.begin() + minCluster2); for (auto& point : data) { if (point.cluster > minCluster2) { --point.cluster; } } --n; } } int main() { vector<DataPoint> data = {{1.0, 0}, {2.0, 1}, {5.0, 2}, {6.0, 3}, {7.0, 4}, {8.0, 5}}; hierarchicalClustering(data); for (const auto& point : data) { cout << point.value << " " << point.cluster << endl; } return 0; } ``` 该程序可以将输入的数据按照差值进行聚类,并输出每个数据点所属的簇的编号。输入的数据是一个包含六个数据点的向量,每个数据点包含数据本身和所属的簇的编号。在程序中,我们首先对每个数据点初始化一个簇的编号,然后进行层次聚类,最终得到每个数据点所属的最终簇的编号。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值