Ubuntu 安装PHP找不着BZip2

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/handsome_926/article/details/77933926

错误如下:

checking for BZip2 in default path... not found
configure: error: Please reinstall the BZip2 distribution

我已经安装了bzip2,应该是需要安装bzip2-dev,可是运行命令sudo apt-get install bzip2-dev 结果是:E: 无法定位软件包 bzip2-dev
最后在Ubuntu bzip2 package 发现该库在Ubuntu的真正名字是libbz2-dev,所以执行如下命令配置通过:

sudo apt-get install libbz2-dev

另外,若出现 configure: error: Cannot find OpenSSL's libraries 这个错误,可尝试安装这个:

sudo apt-get install libcurl4-openssl-dev 

如果还不行可以链接一下:

ln -s /usr/lib/x86_64-linux-gnu/libssl.so /usr/lib

没有更多推荐了,返回首页