S - Spell checker

题目描述:

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.
Input
The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character ‘#’ on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character ‘#’ on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.
Output
Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ‘:’ (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.
Sample Input
i
is
has
have
be
my
more
contest
me
too
if
award

me
aware
m
contest
hav
oo
or
i
fi
mre

Sample Output
me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me
题意:首先给出一些字符串(以#结束),作为词典。然后在不断给出要查找的字符串(以#结束)。查找规则为:
1,如果有一模一样的则直接输出。
2,如果给要查找的字符串加一个字符,能被查找到,就输出。
3,如果给要查找的字符串减去一个字符,能被查找到,输出。
4,如果给要查找的字符串换一个字符,能查找到,输出。
分析:这其实直接暴力查找就可以做出了,有一个坑就是在字符串相等的时候,具体见代码注释。

#include"stdio.h"
#include"string.h"
void Input_str(char str[][16],int *n)
{
    int i=0;
    while(gets(str[i])&&str[i][0]!='#')
        i++;
    *n=i;
}
int main()
{
    char str[10001][16];
    char str1[16];
    int n,mark;
    Input_str(str,&n);
    while(gets(str1)&&str1[0]!='#')
    {
        int len1=strlen(str1);
        mark=0;
        for(int i=0;i<n;i++)
            if(strcmp(str1,str[i])==0)
                {
                    printf("%s is correct\n",str1);
                    mark=1;
                    break;
                }
        if(mark==1)
            continue;
        printf("%s:",str1);
        for(int i=0;i<n;i++)
        {
            int len=strlen(str[i]);
            int ans=0;
            if(!(len==len1||len==len1+1||len==len1-1))
                continue;
            if(len1<len)
            {
                for(int j=0;j<len;j++)
                {
                    if(str[i][j]==str1[ans])
                        ans++;
                    if(ans==len1)
                        break;
                }
                if(ans==len1)
                    printf(" %s",str[i]);
            }
            else
            if(len1>len)
            {
                for(int j=0;j<len1;j++)
                {
                    if(str1[j]==str[i][ans])
                        ans++;
                    if(ans==len)
                        break;
                }
                if(ans==len)
                    printf(" %s",str[i]);
            }
            else
                if(len1==len)
                   {//这里是一个坑点,注意这里的循环只能这样,
                   //和上面的循环判断有些区别,虽然我也觉得没差别
                       for(int j=0,k=0;j<len;j++,k++)
                         if(str[i][j]==str1[k])
                           ans++;
                       if(ans==len1-1||(ans==len&&strcmp(str1,str[i])==0))
                           printf(" %s",str[i]);
                   }
        }
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值