Spell checker(字符串)

该博客介绍了如何设计一个拼写检查器,通过增删替换单个字母检查输入单词是否能在字典中找到匹配项。
摘要由CSDN通过智能技术生成
Spell checker
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 24928 Accepted: 9112

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source


题意:

#号以上给出字典中的单词,为第一部分

#以下每给出一个单词就要进行判断看该单词是否能通过增加一个字母,删去一个字母,替换一个字母的方式得到字典中的词汇

如果找到一样的输出%s is correct便进行下一单词的处理

否则找出所有该单词通过变化得到的字典中的单词

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct node
{
   char word[20];
   int len;
}q[10010];
int main()
{
    char s[20];
    int j=-1;
    while(~scanf("%s",q[++j].word))
    {
         if(q[j].word[0]=='#')
            break;
          else
          {
            q[j].len=strlen(q[j].word);
          }
    }//以上为字典
    int n=j,lens;
    while(~scanf("%s",s))
    {
       lens=strlen(s);
       if(s[0]=='#')
       break;
       int flag1=1;
       for(int i=0;i<n;i++)
       {
           if(!strcmp(s,q[i].word))//先判断是否有完全一样的
           {
              printf("%s is correct\n",q[i].word);
              flag1=0;
              break;
           }
       }
       if(flag1==0)
       continue;
       if(flag1==1)
           {
             printf("%s:",s);
           }
       for(int i=0;i<n;i++)
       {   int cnt=0;
           if(q[i].len==lens)//长度相等看是否为可替换的情况
           {
               for(int k=0;k<lens;k++)
               {
                   if(q[i].word[k]!=s[k])//只有一个字母不一样便可替换
                   {
                      cnt++;
                   }
                   if(cnt>1)
                   break;
               }
               if(cnt==1)
               {
                  printf(" %s",q[i].word);
               }
           }
           else if(q[i].len==lens+1)//输入的串比字典中的多一个字母
           {
               for(int k=0;k<q[i].len;k++)//把每一个字母都删除一遍
               {   char ch[20];
                   strcpy(ch,q[i].word);
                   for(int t=k;ch[t];t++)//删除
                   {
                       ch[t]=ch[t+1];
                   }
                   if(!strcmp(ch,s))//直到删除后一样为止
                   {
                      printf(" %s",q[i].word);
                      break;
                   }
               }
           }
           else if(q[i].len==lens-1)//输入的串比字典中的少一个字母,就对字典中的串进行删除,和上一个一样
           {
                for(int k=0;k<lens;k++)
                {
                    char ch1[20];
                    strcpy(ch1,s);
                    for(int t=k;ch1[t];t++)//删除
                    {
                        ch1[t]=ch1[t+1];
                    }
                    if(!strcmp(ch1,q[i].word))
                    {
                      printf(" %s",q[i].word);
                      break;
                    }
                }
           }
       }
       printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值