Palindrome

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source




/*题意:
给一串字符,问最少加多少个字符可以使它变成回文字符串。
(回文字符串=从左往右看 和 从右往左看 串相同*/
//方法一;非递归;
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
short dp[5005][5005];//计入构成回文串所需加的最小字符;
char a[5005];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        getchar();//取消回车;
        gets(a);
        for(int i=0;i<n;i++)
        {
            dp[i][i]=0;//初始化:
            dp[i][i+1]=(a[i]==a[i+1]?0:1);
        }
        for(int i=1;i<=n;i++)
            for(int j=0;j<n-i;j++)//注意范围;
        {
             if(a[j]==a[j+i])
                dp[j][j+i]=dp[j+1][j+i-1];//移到下一组;
             else
                dp[j][j+i]=min(dp[j][j+i-1],dp[j+1][j+i])+1;//增加一字符;
        }
        cout<<dp[0][n-1]<<endl;
    }
    return 0;
}
/*
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
char a[5005];
int dp[5005][5005];
int getdp(int i,int j)//成为字符串的最小插入字符数,递归法;
{
    if(i==j)//一个字符;
        return 0;
    if(i+1==j)//两个字符;
        return a[i]==a[j]?0:1;
    if(dp[i][j]!=-1)//最小插入的字符数;
        return dp[i][j];
    if(a[i]==a[j])
        return dp[i][j]=getdp(i+1,j-1);
    else
        return dp[i][j]=min(getdp(i,j-1),getdp(i+1,j))+1;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        getchar();
        gets(a);
        memset(dp,-1,sizeof(dp));
        cout<<getdp(0,n-1)<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值