A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.
As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5 Ab3bd
Sample Output
2
题意:回文是一种对称的字符串,也就是说,从左到右以及从右到左读取相同的字符串。您要编写一个程序,给定一个字符串,该程序确定要插入字符串以获得回文的最小字符数。
例如:通过插入两个字符,字符串“Ab3bd”可以转换为回文(“dAb3bAd”或“Adb3bdA”)。但是,插入少于2个字符不会产生回文。
题解:正着把字符串输入一遍,倒着把字符串输入一遍,求其最长公共子序列,然后用字符串的长度减去最长公共子序列,便求出需要添加的字符个数。
由于数据太大会造成内存超限,所以此处使用滚动数组来提高空间利用率。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[5001],s[5001];
int dp[2][5001];
int main()
{
int n;
while(~scanf("%d",&n))
{
int i,j,k=0;
getchar();
memset(dp,0,sizeof(0));
for(i=0; i<n; i++)
scanf("%c",&a[i]);
for(i=n-1; i>=0; i--)
s[k++]=a[i];
int m=n;
for(i=0; i<n; i++)
{
for(j=0; j<m; j++)
{
if(a[i]==s[j])
dp[(i+1)%2][j+1]=dp[i%2][j]+1;
else
dp[(i+1)%2][j+1]=max(dp[i%2][j+1],dp[(i+1)%2][j]);
}
}
printf("%d\n",n-dp[n%2][n]);
}
return 0;
}