poj 2251 搜索

Dungeon Master
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13923 Accepted: 5424

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!
 
这道题最坑人的地方在于poj上将他分类为dfs,结果一写就超时,其实写最短路一般肯定是bfs,哎,经验还是太浅了。
这道题还有一个值得注意的地方就是这是个3维的迷宫,只需要加上上下两个方向就行了,其他的就是简单的bfs。
这道题wa了半天,居然是我忘记把文件输入输出那句话给删了,尼玛!
下面是代码:
 
#include <cstdio>
#include <cstring>
#include <iostream>
#define pan(a,b,c) (a<=b&&b<=c)
using namespace std;

int dir[6][3]={{0,0,-1},{0,0,1},{-1,0,0},{1,0,0},{0,-1,0},{0,1,0}};
char map[35][35][35];
int vis[35][35][35];
int t,m,n,flag;
struct node{
     int x,y,z;
     int num;
}que[30010];

void bfs(int sx,int sy,int sz){
      int head=0;
      int tail=1;
      que[0].x=sx;
      que[0].y=sy;
      que[0].z=sz;
      que[0].num=0;
      vis[sx][sy][sz]=1;
       flag=0;
      int xx,yy,zz;
      while(head<tail){
           for(int i=0;i<6;i++){
               xx=que[head].x+dir[i][0];
               yy=que[head].y+dir[i][1];
               zz=que[head].z+dir[i][2];
               if(map[xx][yy][zz]=='E'){//搜到终点
                   printf("Escaped in %d minute(s).\n",que[head].num+1);
                   flag=1;
                   break;
               }
               if(pan(1,xx,t)&&pan(1,yy,m)&&pan(1,zz,n)&&vis[xx][yy][zz]==0&&map[xx][yy][zz]=='.'){//如果在迷宫内,并且未走过
                      que[tail].x=xx;
                      que[tail].y=yy;
                      que[tail].z=zz;
                      que[tail].num=que[head].num+1;
                      vis[xx][yy][zz]=1;
                      tail++;
               }
          }
            if(flag)
               break;
               head++;//flag不为1,那就要在继续往后走
      }
      if(!flag)
          cout<<"Trapped!"<<endl;
}

int main(){
     //freopen("input.txt","r",stdin);
     //freopen("output.txt","w",stdout);
     int i,j,k;
     int sx,sy,sz;
     while(scanf("%d%d%d",&t,&m,&n)!=EOF){
           if(t==0&&m==0&&n==0) break;
           for(i=1;i<=t;i++)
               for(j=1;j<=m;j++)
                   for(k=1;k<=n;k++){
                        cin>>map[i][j][k];
                        if(map[i][j][k]=='S'){//找到起点
                              sx=i;
                              sy=j;
                              sz=k;
                        }
                   }
                   memset(vis,0,sizeof(vis));
                   bfs(sx,sy,sz);
     }
     return 0;
}


POJ2251是一个经典的题目,也被称为"水仙花的谜题"。该题目要求在一个三维的迷宫中找到从起点到终点的最短路径。 在这个题目中,迷宫由一个3D的数组表示,每个位置上的值代表了该位置的状态。其中,0表示可以通过的路径,1表示墙壁,2表示起点,3表示终点。你需要编写一个程序来找到从起点到终点的最短路径,并输出路径的长度。 解决这个问题的一种常见方法是使用广度优先搜索(BFS)算法。BFS算法可以从起点开始,逐层遍历迷宫中的位置,直到找到终点或者遍历完所有可达位置。在遍历过程中,你需要记录每个位置的距离和路径信息,以便找到最短路径。 以下是解决该问题的大致思路: 1. 定义一个队列,将起点加入队列,并标记起点已访问。 2. 使用循环来遍历队列中的元素,直到队列为空。 3. 在循环中,取出队列中的元素,并获取其相邻可达位置。 4. 对于每个相邻位置,判断是否为终点,如果是则输出最短路径长度并结束程序。 5. 如果不是终点,则判断该位置是否为可通过的路径,并且未被访问过。如果满足条件,则将该位置加入队列,并更新距离和路径信息。 6. 重复步骤2-5,直到找到终点或者遍历完所有可达位置。 这只是一个简单的介绍,实际解决该问题还需要考虑一些细节,比如如何表示迷宫、如何判断位置的合法性等。你可以在编写代码时参考相关的算法和数据结构知识。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值